Update from v2.6.1 to v2.7.1 - error": "authorization not found"- lot of trouble and solution

Hello together,
Hope this posts helps someone:
Today I ran into trouble with the update from v2.6.1 to v2.7.1.
I did the update last weekend. By the first looks of it, everything went fine. Influx came up with the login screen, I could log in and all the data went into the database.
Today I was forced to do a reboot fo the server. This is were the trouble started.

After the rebooting the onboarding webpage appeared. Log in using the CLI didn’t work either.
In the systemlog there were a lot of

Unauthorized    {"log_id": "0Ue9Baal000", "error": "authorization not found"}


Caused a lot of headache but I’ve found out what had happened and what to do to get everything up and running.

The paths of the installation have been altered after the update. On the v2.6.1 machine the engine, bolt and config path was:


a “ls -al” showed all of the files and folders.

root@influx2:/var/lib/influxdb/.influxdbv2# ls -al
total 52
drwx------ 3 influxdb influxdb      7 Jan 22  2023 .
drwxr-x--- 7 influxdb influxdb      9 Sep 21 15:10 ..
-rw-r--r-- 1 influxdb nogroup     185 Jan 22  2023 config.toml
-rw------- 1 influxdb nogroup     492 Jan 22  2023 configs
drwx------ 5 influxdb nogroup       5 Jan 22  2023 engine
-rw------- 1 influxdb nogroup  131072 Sep 21 14:50 influxd.bolt
-rw-r----- 1 influxdb influxdb 122880 Jan 22  2023 influxd.sqlite

The documentation says those files are stored here:

Engine path: /var/lib/influxdb/engine/
Bolt path: /var/lib/influxdb/influxd.bolt
SQLite path: /var/lib/influxdb/influxd.sqlite
Configs path: /var/lib/influxdb/configs
Default config file path: /etc/influxdb/config.toml

When I rebooted the system, influx didn’t find those files and created new ones at the default location. I stopped the server, moved all of the files from /var/lib/influxdb/.influxdbv2 to their default location and everything worked again.

FYI: I run influx on a debian 10 (buster) lxc container and made a few months ago the step from v1.8 to 2.6.