Timezone problem

I am very new in InfluxDB. I have InfluxDB, Kapacitor and Chronograf installed on QNAP NAS. It collects data form Domoticz (installed on Raspberry Pi) via build-in Domoticz interface to InfluxDB. Grafana is installed on my Desktop PC.
My timezone is Europe/Warsaw. The problem I have is that Grafana, Chronograf shows time according to my timezone. But if I want to query database from CLI, the time is presented according to GMT time. All data in database are stored with UTC timestamps. I checked it using on-line Unix timestamp converter available on Internet.
But if I query database directly from QNAP CLI presents a time according to GMT. The same situation is when I query DB over network using CURL.
Below syntax of my CLI query:

Blockquote
influx -precision rfc3339 -execute “SELECT mean(“value”) AS “mean_value” FROM “nanopi”.“autogen”.“Temperature” WHERE time  >
now() - $time GROUP BY time(1s) FILL(none)”

It returns proper values but time is specify according to GMT

So i want to add tz() to query. Below query and result

Blockquote
influx -precision rfc3339 -execute “SELECT mean(“value”) AS “mean_value” FROM “nanopi”.“autogen”.“Temperature” WHERE time  >
now() - $time GROUP BY time(1s) FILL(none) tz(‘Europe/Warsaw’)”
ERR: error parsing query: unable to find time zone Europe/Warsaw
Warning: It is possible this error is due to not setting a database.
Please set a database with the command “use <database>”.
error parsing query: unable to find time zone Europe/Warsaw

What I am doing wrong? Any syntax error? Be so kind to help as I am newbie…

Try to replace the single quotes around Europe/Warsaw with double quotes. If that works, there’s a typo in the docs.

On what OS is InfluxDB running on?

I think the code calls time.LoadLocation. Maybe that location is missing in the database on that OS.

https://golang.org/pkg/time/#LoadLocation

I find out source of problem:

https://stackoverflow.com/questions/52129582/unable-to-find-time-zone

This is a known bug, see:
https://github.com/influxdata/influxdb/issues/10196

As documentation stands, InfluxDB should use local time by default or timezone specified in query. In my case GMT+1 is a local time.

And workaround. InfluxDB is installed on QNAP NAS with QTS operating system. Zone info is located in /etc/zoneinfo/Europe and there is no definition for Warsaw. Below the content of this dir:

Amsterdam Athens Belgrade Bucharest Helsinki London Moscow Paris Sarajevo

Thats all. No Brussels, no Berlin etc. So I changed in query Europe/Warsaw to Europe/Paris and now works OK.
Nevertheless there is a bug in DB from my point of view.