Telegraf Windows Service issue


I am running Telegraf 1.13.3 as a service under Windows 10 using the -service install … So far I also used the --config path\file.conf to specify the config file to use. No problem at all.
Now I wanted to use multiple config files and specify --config-directory option. But that did not work. So I searched Internet and found this has been an issue in ealier versions as well as the workaround to change the service setting once telegraf service is installed. This should be possible using sc config telegraf -binPath= “…”.
I tried all that but without succes. The telegraf service keeps failing leaving in the Event log a message it can not find a config file telegraf.conf in “C:\Program Files…” (besides the typical Linux settings as well).
I do not and don’t want to use “C:\Program Files…”, I want to specifiy the config directory in a specific place.
I also read this should have been solved from version 1.8 or later.
So, what am I missing here?
Thx in advance for pointing me in the right direction as I am stuck in a dead end here.