Telegraf.service: failed with result 'exit-code'

when i tried service telegraf status
telegraf.service is failed and shows telegraf.service: failed with result ‘exit-code’

Tried telegraf --config /etc/telegraf/telegraf.conf --test
do have output.

Anyone can help?

Thanks Antony

Telegraf is installed on a virtual machine. The version is 1.15.4

when I tried service telegraf status, the output is like this.

then I tried telegraf --config /etc/telegraf/telegraf.conf --test
the outputs were correct as they were in kafka
so the config is correct.

I also tried systemctl restart telegraf and stop telegraf then telegraf -debug
but service is still failed.

so I think maybe the problem is about system process.

Show us the output, or show us the config.

Also, which version are you using, which operating system is it on, and which
version of that?

Is this the first time you installed telegraf on this machine, or have you had
it working previously and now it’s failing?


–config output is like this

This is the log from journalctl -eu telegraf .
The error message is related to “open /etc/telegraf/telegraf.conf permission denied”.

Anyone can help?

Why are you getting permission denied when telegraf tries to load its own config??

Other things to try
Can you start telegraf with a blank config ?

telegraf config > ~/telegraf.conf
telegraf --config ~/telegraf.conf

If this works, check your config is valid /bad formatting .