Telegraf performing snmptable instead of snmpwalk

telegraf

#1

Hello everyone,
I would like to share with you my current struggle to get SNMP info collected with Telegraf and inserted into influxdb

2018-12-18T18:12:49Z D! Attempting connection to output: influxdb
2018-12-18T18:12:49Z D! Successfully connected to output: influxdb
2018-12-18T18:12:49Z I! Starting Telegraf 1.8.3
2018-12-18T18:12:49Z I! Loaded inputs: inputs.snmp
2018-12-18T18:12:49Z I! Loaded aggregators:
2018-12-18T18:12:49Z I! Loaded processors:
2018-12-18T18:12:49Z I! Loaded outputs: influxdb
2018-12-18T18:12:49Z I! Tags enabled: host=gtomonitoring.netsize.com
2018-12-18T18:12:49Z I! Agent Config: Interval:10s, Quiet:false, Hostname:"gtomonitoring.netsize.com", Flush Interval:10s
**2018-12-18T18:12:50Z E! Error in plugin [inputs.snmp]: initializing table snmp_mt: getting table columns: exit status 1: Was that a table? OTACS-MIB::otacsMtNumber**

This is the pretty same error I get if I run:

[root@gtomonitoring ~]# snmptable -v2c -c public IP:PORT OTACS-MIB::otacsMtNumber
Was that a table? OTACS-MIB::otacsMtNumber

I was using this configuration:

[inputs.snmp]]
agents = [ “IP:PORT” ]
version = 2
community = “public”

[[inputs.snmp.table]]
name = “snmp_mt”
oid = “OTACS-MIB::otacsMtNumber”
inherit_tags = [ “hostname” ]

Indeed, this is not a table, but is it Telegraf supposed to work with SNMPWALK instead of SNMPTABLE?

Thanks


#2

This is expected, but I don’t think it is necessarily what we want. The only workaround is to specify the fields for the table directly and remove the table OID, but this will use a GET, there is more info on this issue.


#3

Hello daniel, thank you so much for your response.
The only problem is that there are so many fields to be collected and it could be good if we had a way to make a walk on all the fields from an OID.
Do you think it could be a good feature?
Thanks!


#4

Oh, I’ve just seen you are on very advanced discussion about this topic.
And your approach of always use walk sounds nice to me.
Let us hope we can do this happen :slight_smile: