Telegraf---->inputs.amqp_consumer

The following is my configuration:

AMQP consumer plugin

[[inputs.amqp_consumer]]

AMQP url

url = “amqp://localhost:5672/influxdb”

AMQP exchange

exchange = “telegraf”

AMQP queue name

queue = “mytest”

Binding Key

binding_key = “hello”

Controls how many messages the server will try to keep on the network

for consumers before receiving delivery acks.

#prefetch_count = 50

Auth method. PLAIN and EXTERNAL are supported.

Using EXTERNAL requires enabling the rabbitmq_auth_mechanism_ssl plugin as

described here: https://www.rabbitmq.com/plugins.html

auth_method = “PLAIN”

Optional SSL Config

ssl_ca = “/etc/telegraf/ca.pem”

ssl_cert = “/etc/telegraf/cert.pem”

ssl_key = “/etc/telegraf/key.pem”

Use SSL but skip chain & host verification

insecure_skip_verify = false

Data format to output.

Each data format has its own unique set of configuration options, read

more about them here:

https://github.com/influxdata/telegraf/blob/master/docs/DATA_FORMATS_OUTPUT.md

data_format = “influx”

Start telegraf service prompt information:

2017/05/09 11:37:33 E! Error parsing telegraf.conf, Undefined but requested input: amqp_consumer.

Please enlighten!Thanks very much

@mfhjnvc090852 What version of telegraf are you running?

The version I use is v1.2.1

@mfhjnvc090852 That plugin isn’t included in the 1.2 release. It will be included in the telegraf 1.3 release. Here is a link for the 1.3 release candidate downloads.