Strange disk usage issue

Hi community,

I’m using influx 2.3.0 to store several temperature measurements provided by an OpenHAB instance. I have created a bucket for the values with an retention policy of 90 days.

Today I found out that the data is using a lot more disk space than expected. I reduced the RP to 30 days but the disk space was still the same. Then I took a look into the influx folders:

root@h2880936:/var/lib/influxdb/engine# du -sch */*
6,6G    data/3457ae9f3bc3f2b5
908K    data/783263d9c64b08c5
76K     data/b356cf672dfaed7b
23M     wal/3457ae9f3bc3f2b5
40K     wal/783263d9c64b08c5
16K     wal/b356cf672dfaed7b
6,6G    insgesamt

My OpenHAB bucket has the ID 783263d9c64b08c5 and its folders are very small. I don’t know to what the 6.6G folder belongs to. Here is the list of buckets configured in influx:


Do you have any idea what this data is and how I can get rid off it?

Thanks in advance,

Update: One day later I moved the folder to /tmp and restarted influx to see what happens. The engine started without any problems and all data is still available. Now, a few days later, the folder wasn’t recreated and for me the problem is solved without knowing what data I deleted :smiley:


1 Like

Another update: Today I checked the folder sizes and again I found another huge folder.

sudo du -hs /var/lib/influxdb/engine/data/*
5,2G    /var/lib/influxdb/engine/data/3457ae9f3bc3f2b5
1,8M    /var/lib/influxdb/engine/data/783263d9c64b08c5
76K     /var/lib/influxdb/engine/data/b356cf672dfaed7b

I then deleted the 3457ae9f3bc3f2b5 folder and everything is still working… Is there anybody out there having an idea what this folder is all about?


Hi @ballertom
as I see the same behavior: Do you still have the same problem? Are you removing the folder manually or periodically?

Hello @chrisper,
Are you using 2.3 too?
I wonder if this was solved in an update.
I’ve literally never heard of this. You deleted that large file and non of the data was compromised?
So strange.
I’d try deleting it and hopefully not having to delete this periodically as I’ve never encountered this before.

Hi @Anaisdg,
I’m using InfluxDB v2.7.1 (git: 407fa622e9) build_date: 2023-04-28T13:24:27Z in a docker container.
Till now I don’t miss any data. The deleted directory seems not to be related to any bucket (id is different to any known bucket). But, as soon as I start the container, the ghost-bucket is created again and size is growing. Since last post it grew to a size of 2.8 GB.