Remote SNMP Host in Chronograf host list

#1

Is there any way I can see all remote hosts monitor by SNMP on Cronografs default Host List. I don’t want to run telegraf on my remote machine.

#2

Hi!
I dont know exactly what do you need.

If you need to monitor ,by snmp, remote hosts, you dont need it to install telegraf agent in remote hosts.
Using the following part in telegraf configuracion:

[[inputs.snmp]]
agents = [ “xx.xx.xx.xx:161”,“xx.xx.xx.xx:161” ]
version = 2
community = "comunity"
name = “snmp”

This is the way to declare remote host in telegraf, in grafana you can find like “agent_host” i suppose that in chronograf is the same.

#3

Thank you for your quick reply.

I am able to collect data. And yes I can find from Chronograf/Grafana too from agent_host TAG. But I want to add those SNMP monitored hosts and all its graph automatically added to any view of Chronograf.

Just like All hosts monitored by Telegraf agent is added on Chrnograf “HOST LIST” tab. I want to add my SNMP monitored hosts here. Is it possible?

#4

I think is not possible but i dont know if you add a new tag named hostname in snmp metrics it could be possible see it there like a hostname.

#5

Tried that one too but didn’t work.

#6

DId you tried using the following config?

[[inputs.snmp.field]]
   name = "hostname"
   oid = "RFC1213-MIB::sysName.0"
   is_tag = true
#7

Yes did that same. But no luck :frowning:

#8

I believe Chronograf uses the host tag to create the host list. Keep in mind that this is the tag Telegraf uses to indicate what host it is running on, so if you set it to the snmp system name you will lose the ability to see what host is collecting the data.

#9

It works Daniel! Thank you.

But I tried it before, it wasn’t working that time, so i have doped the database this time and works fine.
I wasn’t sure, but i think it was my fault cause I tried a lot of configuration setting some of them might have problem.