[inputs.snmp_trap] Error resolving OID oid=.

I am sending traps from a Cisco WLC and telegraf is reporting that OID cannot be translated:

Telegraf logs:

ubuntu@ip-172-31-21-211:/$ journalctl -xeu telegraf.service
Nov 25 11:35:21 ip-172-31-21-211 telegraf[12399]: 2023-11-25T11:35:21Z I! [inputs.snmp_trap] Listening on udp://:162
Nov 25 11:35:30 ip-172-31-21-211 telegraf[12399]: 2023-11-25T11:35:30Z E! [inputs.snmp_trap] Error resolving OID oid=., source=x.x.x.x: not found
lines 3233-3293/3293 (END)

Telegraf config

#   example: "udp://:16200"
 service_address = "udp://:162"
  path = ["/home/ubuntu/mibs"]
 version = "2c"

I have the mib files of this device in the folder:

ubuntu@ip-172-31-21-212:/$ ls /home/ubuntu/mibs -la
total 33064
drwxrwxr-x 2 ubuntu ubuntu   36864 Nov 25 10:55  .
drwxr-x--- 8 ubuntu ubuntu    4096 Nov 25 11:32  ..
-rw-rw-r-- 1 ubuntu ubuntu   16206 Nov 25 10:54  ADSL-DMT-LINE-MIB-V1SMI.my
-rw-rw-r-- 1 ubuntu ubuntu   24097 Nov 25 10:54  ADSL-DMT-LINE-MIB.my
-rw-rw-r-- 1 ubuntu ubuntu  129186 Nov 25 10:54  ADSL-LINE-MIB-V1SMI.my
-rw-rw-r-- 1 ubuntu ubuntu  159225 Nov 25 10:54  ADSL-LINE-MIB.my
-rw-rw-r-- 1 ubuntu ubuntu      14 Nov 25 10:54  AIRESPACE-WIRELESS-CAPABILITY-V1SMI.my
-rw-rw-r-- 1 ubuntu ubuntu   68315 Nov 25 10:54  AIRESPACE-WIRELESS-CAPABILITY.my
-rw-rw-r-- 1 ubuntu ubuntu  513788 Nov 25 10:54  AIRESPACE-WIRELESS-MIB-V1SMI.my
-rw-rw-r-- 1 ubuntu ubuntu  682630 Nov 25 10:55  AIRESPACE-WIRELESS-MIB.my

I tried changing snmp_translator under agent, it doesnt work (same error), even though I am able to translate it:

snmp_translator = "netsnmp"
ubuntu@ip-172-31-21-211:~$ snmptranslate .

I am not interested in translating anything really, I just want to receive the input and I process it later myself. Is there a way to disable translation?

I also tried sending a manual test trap from the same host:

snmptrap -v 2c -c public localhost:162 '' i 123456

And I get the same error on Telegraf:

ubuntu@ip-172-31-21-211:~$ journalctl -xeu telegraf.service
Nov 25 11:57:24 ip-172-31-21-212 telegraf[12469]: 2023-11-25T11:57:24Z E! [inputs.snmp_trap] Error resolving OID oid=., source= not found

Hello @Vasa,
I’m not sure but it looks similar to:


What version of telegraf are you using?

Currently running 1.8.10.
Looks identical to the #2, which should have be fixed in the release I am running.