[inputs.net.tagdrop] doesn't drop tags

Edit:
Sorry - rookie mistake - was looking at the wrong server :frowning:

It appears that I cannot delete this post. If an admin can do so, please do.

Related to:


We have some hosts which have many docker containers with virtual ports being spun up and shut down. This leads to Grafana graphs having dozens of entries.

It appears from the above that interface_exclude has been considered, but never implemented, so I’ve gone with tagdrop, rather than a list of globs to include (because that’s messy).

Here’s the relevant part of my telegraf.conf:

[[inputs.net]]
  ignore_protocol_stats = true
  [inputs.net.tagdrop]
    interface = ["veth*"]

This query on the influxdb database:
SHOW SERIES WHERE "interface"='veth1b1d609'

Returns:
{"results":[{"series":[{"columns":["key"],"values":[["net,interface=veth1b1d609,server=blah"]]}]}]}

So the two tags are server and interface, yes?

I restart telegraf with the new configuration, drop the series in influxdb, just to make sure, and 60s later, it’s back again.

I’ve tried explicitly dropping veth1b1d609, just to check.
I’ve tried ["*veth*"] instead of ["veth*"], just in case the server name was included.

What am I missing, here?
Frustrated.

Thanks.