Input plugin cannot load information from configuration file

I have been trying to add another field to my input plugin that can receive information from the configuration file, allowing greater user flexibility in providing settings.
I have defined the struct as follows:

type Plugin struct {
	Address       string  `toml:"address"` 
	lines_to_read string  `toml:"lines_to_read"`

The configuration toml file is then arranged as follows:

    address = "temp/filepath.txt"
    lines_to_read = "20"

I consistently receive the following error whenever I test this config file:

E! error loading config file plugin.conf: plugin inputs.plugin: line 1156: configuration specified the fields ["lines_to_read"], but they weren't used

There never appears to be any problems inputting or changing the address marker. In fact, the plugin will run if the lines_to_read label is removed.

Things I’ve tried:
rerun make command with different PluginConfig files to verify the make is updating the system. No problems with make and settings are being updated.
reran “./telegraf -sample-config -input-filter plugin > plugin.conf” to try to update the configuration file. Does not help.
tried removing underscores to see if it would change anything. No improvement.

I do not know what could be causing this error for specifically the second struct value and not the first. Let me know if anyone can figure out what was wrong about this config file.

Found the problem. The GitHub - influxdata/toml: TOML parser and encoder library for Golang unmarshalling doesn’t require underscores in the toml file, but it does require them in the struct, which I forgot to change.
Removing the underscores and capitalizing the term got the program working again.

Hello @spacecoder,
Thanks for sharing your solution!
What plugin are you creating! Any chance you want to submit a PR or add it to