InfluxDB queries do not show the results after a certain time

influxdb
#1

Hi,

I have a database of about 10 measurements with 100,000 time-value pairs each, with rows added continuously but not so frequently (1 row per minute) in InfluxDB 1.1.0. The retention policy is autogen.

Recently, every query to the database stopped showing the data with timestamp after a certain time (2017-07-23 23:59, to be exact). I suspected a problem with the scripts that I use to write to the database, but the logs show no error at all (response 204 from Influx for every write operation).
Surprisingly, backing up the database and restoring it in another Influx instance shows that the data is effectively added to the database. So, to recap, my main InfluxDB instance just doesn’t show the query results after a certain point in time, even if the rows are there.

I checked the disk usage of the db too, and it is well below a “worrying” size (just in the order of 100 MB), and I have plenty of free space.

Can someone help me pinpoint the source of the problem? Just hope for a human error, and not a bug :grin:

#2

Can you post one of the queries?

#3

Well, I tried with different queries, on different measurements, both using the http API and the CLI. Always with the same results.
I also dumped all the db data to a json file and reloaded it to a new db using a script (through http). For some time (several hours) the problem seemed to be solved, but then the queries started again to “truncate” the values inserted after a certain time.

However, just to give you an example of the queries, I use something like:
select value from RelativeHumidity where time > now() - 2h order by time desc

P.S. The database does not contain any tags.

#4

Any errors in the log? Can you test on 1.3.6? If it’s still an issue on 1.3.6, can you create an issue with repro steps?