Influxdb logfile does not create logfile

influxdb
#1

I am using ubuntu 16.04 and latest version of influxdb.

I start it using sudo service influxdb start command. I have changed any log setting in the conf file.

But when I check /var/log/influxdb/ nothing is there.

I need logs, where is the problem ?

#2

Assuming your running on a systemctl system influxdb logging can be found via

journalctl -u influxdb.service

also check out https://docs.influxdata.com/influxdb/v1.2/administration/logs/

1 Like
#3

I have written that I start it using sudo service influxdb start.

If the logs are stored in journalctl, how can I get those in a log file ?

#4

Looks like your running a recent version of Ubuntu, I don’t use it, but I would venture a guess “service” is redirected to systemctl like most other distros. A few mins on Google should answer that.
There is an option on journalct (ForwardToSyslog) usually its on by default, however, that’s going to vary between distros.
This may help with with what you would like to do. https://www.loggly.com/ultimate-guide/linux-logging-with-systemd/

I’ve not tried what you are looking to do, so I can’t really help with that specifically.

Cheers

#5

What version of the OS are you using @Luv? That will help us drill down to the answer for you!

#6

Hello,
i know this issue is long ago but i have the same problem, that no logging is happening on my InfluxDB.

I am running under Debian 9 (stretch). It is running in a VM under Proxmox but this should be a problem.

Thank you in advance for some help !

#7

Hi , have you tried as suggested above …

journalctl -u influxdb.service

you can add a tail to get the last 100 lines

journalctl -u influxdb.service | tail -100

here is some information about logging :

logging