Influxdb java api not for jdk 1.7 but 1.8

Hi,

I try to use influxdb java API with jdk 1.7 like the "Build Requirements"

Build Requirements

Java **1.7**+
Maven 3.0+

But you need jdk 1.8 to compile and run not jdk 1.7.
Could you change the Build Requirements information ?

Regards.
Vincent D.

Can you give the PR a +1? https://github.com/influxdata/influxdb-java/pull/312