Influxdb https + auth and http=disable, how to create a user?


I am setting up Influxdb + chronograf with ssl+auth.

I am facing 2 weird issues, when setting http = disable :

  • Chronograf can’t connect to InfluxDB since there is no login/password defined in the base (I guess).
  • I can’t use influx CLI in my docker container to create a user.

This is the command I use in the container : influx -ssl -unsafeSsl (as I said, it doesn’t work with http disable even though it seems to connect through https.

With http=enable, this is what I can do in the container :

root@influxdb-deployment-3032093409-fd72d:/# influx                                                                                                              
Failed to connect to https://localhost:8086: Get http://localhost:8086/ping: malformed HTTP response "\x15\x03\x01\x00\x02\x02"
Please use the -ssl flag to connect using SSL.
You may use -unsafeSsl to connect anyway, but the SSL connection will not be secure.
root@influxdb-deployment-3032093409-fd72d:/# influx -ssl -unsafeSsl
Connected to https://localhost:8086 version 1.3.0
InfluxDB shell version: 1.3.0

My configuration :

  enabled = false  # or true in the terminal output example above
  auth-enabled = true
  https-enabled = true
  https-certificate = "/etc/ssl/<cert>.crt"
  https-private-key = "/etc/ssl/<cert>.key"

Basically, is there a way to create a privileged user during influxDB launch ? Am I missing environment variables ? (I am not using any neither for influxDB nor for chronograf)