Influxdb crashing out of memory

You should find something in the log before the crash, it may or not be relevant, but if you don’t check you can’t know.

I’d change the following setting:
max-concurrent-compactions = 1

Maximum number of full and level compactions that can run concurrently. A value of 0 results in 50% of runtime.GOMAXPROCS(0) used at runtime. Any number greater than zero limits compactions to that value.
If you have two cores it won’t make a difference as it’s already one (50% of total cores)…

Another option you could evaluate is to change the index-version to tsi1, which should be more efficient, it requires a migration of the shards. details about the TSI index can be found here