Influxdb 2.2 , org can not be found on org list but is searchable by name or id

I am running InfluxDB OSS 2.2 on Ubuntu server. I am surprised by one of our org lists which is seachable by id influx org list --id id or name influx org list --name name but is not listed on influx org list. It is not visible on the dashboard either. I previously could get data from it in this state from Grafana. What could be the issue here. Thanks.

Hello @Cyrus_Jomo,
Welcome back.
Hmmm…
If you create resources with the CLI or API they won’t be reflected in the UI often.
I’m not sure why come CLI cmds are workign and others arent. That is quite odd.
Is there any data in that org?
I haven’t encountered this before.
Thanks,
Anais

Hello.
Thank you for getting back. Yes I can retrieve data using a script made earlier. But the org is still not in the org list. It was not created by API or CLI but the influxdb UI console.

Thanks

I have tried upgrading to Influxdb 2.3, then to 2.6. Still doesn’t come up on the UI but can be searched by id or name.

Hey @Anaisdg , We have another Org down. We cannot access it via the GUI. Trying to create a new org with similar name an error failed to create because org already exists pops. The org have data and can be accessed via API.