How to avoid OOM

I want to build a low-resource hardware to run influxdb. Low performance is okay, but OOM exceptions are not allowed.

Version: docker image influxdb:2.1
Memory: 1g
Storage capacity: 40g
Data: 1bucket, 2measurement, 3tag, 10field, 10000 series/measurement, 8000 records/series

I have tried to avoid OOM for 3 days, but the memory has risen too fast, especially when the service is restarted, even though my data is less than 500MB.

Is there any plan for me to achieve this? By modifying the configuration file? Switching to the old version? Or is this simply impossible?

Hi @jimliu,
So you can change much of the internal performance architecture with the Influx Config:

Have a look at the memory options there. If you have no need for the system buckets I would also disable them. Have you also set restrictions on the docker container memory size aswell?