Google Sheets Query of InfluxDB Cloud

I have a question regarding querying an InfluxDB Cloud instance using Google Sheets (via an HTTP Query) I am working on for a proof of concept. In a Google Sheets API Script I am using the FETCH command to effectively run the command below. “MY” Tags used to substitute for actual values.*%20from%20MYTABLE

I have also pasted this same query into a browser window with the same result. The output is shown below.

{“results”:[{“statement_id”:0,“error”:“database not found: MYBUCKETNAME”}]}

Can anyone help with the error I am receiving? I have begun to look into DB mapping via the CLI but fail to understand how this accomplished when using a Cloud Instance. Any help is appreciated.

Hello @Jim_Walker,
I find it useful to use the bucketID instead sometimes to avoid any spacing or capitalization issues. Can you try that?

Thank you for the reply. Changing to the BucketID made no difference - Same error code. I was able to resolve this issue though. Here is what I had to do…

  1. Download and install the InfluxDB CLI.
  2. Execute an influx v1 dbrp create command //This will map your bucket to a Database

This allowed my BUCKET to be queried as a DATABASE. It is working very well right now.