Get 405 error when trying to query InfluxDB 3.0 Serverless on Azure

Good day

I set up new Influx severless instance on Azure and set up a DBRP between my bucket and a database named the same thing. I can query the data with the CLI (influx v1 shell) and with the query endpoint but client libraries give me the following error (just when trying to query, writing points work fine with the same client)

I’m using the same Python code in the integration guide on the Web UI, also tried the C# library and the same error.

pyarrow._flight.FlightServerError: Flight RPC failed with message: Received http2 header with status: 405. gRPC client debug context: UNKNOWN:Received http2 header with status: 405 {grpc_status:2}. Client context: IOError: Server never sent a data message. Detail: Internal

Hello @Aghmat,
Why do you want to create a DBRP mapping?
You can query v3 with InfluxQL or SQL directly.
Which client libraries are you using with v3?
You can only use these client libraries with v3:

Maintained here:

That’s because v3 uses Arrow Flight under the hood instead of the query endpoints that were used previously. So the query methods in the new client libraries wrap the Apache Flight clients.