Cant get Field Keys with Flux and InfluxDB 1.8.4

I want to get a list of the fields, but I just cant get it. (flux with influxDB 1.8.4)
Tried the solution from the link and any other field related method from the v1 page.(Flux InfluxDB v1 package | Flux 0.x Documentation)

Error message I got in Chronograph and with API call:
‘error":"error calling function “fieldKeys”: cannot call function, value is of type nil’

Measurements do work!

Please help!

@Anaisdg Can you maybe help? Sorry for asking, but you were my saviour before and I saw in the repo that you were busy with the python lib as well.

@Cas_Altenburg, can you paste in the actual query you’re running?

@scott
I tried:

import "influxdata/influxdb/v1"

v1.fieldKeys(
    bucket: "XXXXXX",
    predicate: (r) => true,
    start: -30d,
)

And

v1.measurementFieldKeys(
    bucket: "xxxxxx",
    measurement: "events",
    start: -30d,
)

v1.fieldTags works but these two do not.

@Cas_Altenburg, v1.fieldKeys() and v1.measurementFieldKeys() were introduced in Flux 0.68.0. I’m guessing you’re using a version of InfluxDB that has an older version of Flux where these functions aren’t available. I’m not sure which version of Flux is packaged with the version of InfluxDB you’re using, but you should be able to find out with this query:

import "csv"
import "runtime"

csv.from(csv: "
#datatype,string,long,string
#group,false,false,false
#default,,,
,result,table,version
,,0,${string(v: runtime.version())}
")