Can't delete a series of data in Influx 1.72!

Hi there,

I’m a bit of a noob atm so please excuse any terminology failings!

I’ve been running an instance of inluxdb for my grafana instance and had started on influxdb 1.24 with the admin panel (1.20) I recently upgraded to current version 1.72 hoping that any optimizations may help me get out this hole but and am still having the same issue where i try and delete a series of data from the database the database goes into an endless cycle at 100% cpu load and keeps churning through trying to delete the data. Since the upgrade at least the churning has stopped!

My database is around 400gb and when i try and remove this particular series the database consumes a further 100gb to take it to 500gb and then falls back to 400gb in an infinite loop.

The series in particular is simply all values to do with a particular linux host. This particular host was a docker instance that had decided to restart itself every 30 seconds and kept making unique “veth-xxx” instances of the NIC every time it was restarted and logging the data to influx.

I believe it probably hit a 10,000 value limit or similar and influx has been tracking all of these values since.

How can i drop the data for the host in question?

I’ve been using the admin panel with the following query.

DROP SERIES WHERE host='myservername'

I’ve even tried the following query which seems to work as i can show the data from it.

DROP TAG VALUES FROM net WITH KEY IN ("interface") WHERE host = 'myservername' AND "interface" =~ /veth/

This never seems to finish.

When i try and get more granular and delete a particular instance it completes with success but the data dosn’t remove!

DROP SERIES WHERE host = 'myservername' AND "interface" = "vethfff429d"

Can someone help me out? It seems that this should be quite straight forward and i’m assuming the sheer amount of measurements that it’s trying to drop is the issue.

In essence what i’m asking is what’s the most efficient way of deleting a large set of data from an influxdb database.

Have u tried
DELETE FROM “Measurement” .