Timestamp bug using influxdb locally (windows, linux and docker environment)


I am testing influxdb for my iot project and I am facing a really weird issue;
when trying to write a Point with a timestamp with time zone, it doesn’t save the actual timestamp, but saves some sort of “default” timestamp every time I try to do this operation (I tried on every os); the weirdest thing is that, with the same source code, I don’t get this bug if I write on my cloud instance.
I tried with different drivers (nodejs, c# ecc) but nothing;
Here’s the source code; again, it works fine if I write on my cloud instance.

const point = new Point('sensors')
  .floatField('ambientHumidity', state.ambientHumidity)
  .floatField('ambientTemperature', state.ambientTemperature)
  .floatField('mainBoardTemperature', state.mainBoardTemperature)
  .timestamp(new Date(dateTimeISO8601Now()))
  .tag("time_zone", ENV_TIME_ZONE)


can someone please explain to me what is happening ?

Hello @disco,
Time in InfluxDB is store in UTC.

Perhaps this accounts for the difference that you’re seeing?