Proxy somehow usable for OAuth 2.0 authentication in Chronograf with Azure AD?

I tried to integrate Chronograf into Azure AD. My problem is that the chronograf in running inside a pod (server) which does not have direct access to the internet. Is there a way to configure a proxy in order for chronograf to use this when accessing “”? The issue can be seen in the pod when using netstat -an. chronograf tries to open a direct connection to (IP: which is not possible/allowed in the environment of my customer. Configuring an “http_proxy” or “https_proxy” didn’t change anything. It seems that chronograf is not using those settings. I am using version 1.8.8 of Chronograf.

~ $ netstat -an
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 1 SYN_SENT
tcp 0 0 :::8888 :::* LISTEN
tcp 0 0 ::ffff: ::ffff: TIME_WAIT

Thanks for any hints, ideas

As I could not find any information in the documentation and did not receive a reply I assume this is simply not supported. Will use basic authentication as workaround.