Librenms + Influxdb cant show ipmi sensor_desc

grafana
influxdb
#1

Hi,

I already successfull to integrated the lenovo server to librenms, and can got temperature with ipmi access

but i need to display the metrics to grafana, to make one dashboard for monitoring with other platform, so i use influxdb to integrate with grafana

but in influxdb , that just show an number, it must be have some metrics sensors there like on librenms

Regards,
RidhoYP

#2

@ridhoyp Welcome to InfluxDB! I’ve got a couple of questions. How are you getting the data into InfluxDB? Telegraf, the native InfluxDB collector, also has an ipmi_sensor plugin that does record these names. Would that work for you?

#3

hi @jackzampolin , i use librenms + os snmp > send its data to influxdb > and then the grafana will show the graph… i will look the telegraf, but for now, we use librenms as based snmp gathering metrics.

1 Like
#4

@ridhoyp What you are seeing has to do with the way the librenms + os snmp is sending the data to InfluxDB. So what you are seeing has to do with whatever connector you are using. The reason I suggested Telegraf is that it has the data you are looking for and is more native to InfluxDB. There is also an snmp plugin that is in production at a number of telecoms doing large scale polling that should work well for you.

#5

Hi @jackzampolin , using telegraf + snmp , https://github.com/influxdata/telegraf/tree/master/plugins/inputs/snmp we must to define what oid we must to capture manually,if we dont know what oid then cant capture it.

i try the ipmi_sensors using the https://github.com/influxdata/telegraf/tree/master/plugins/inputs/ipmi_sensor

it give result timeout and interval not defined =

root@monitoring:/etc/telegraf# telegraf --config telegraf.conf -test
2017/06/13 05:39:24 E! Error parsing telegraf.conf, line 1250: field corresponding to timeout' is not defined in*ipmi_sensor.Ipmi’

but without interval and timeout it be like this =

  • Plugin: inputs.ipmi_sensor, Collection 1
    2017-06-12T22:40:18Z E! Error in plugin [inputs.ipmi_sensor]: failed to run command /usr/bin/ipmitool -H 10.16.100.64 -U USERID -P PASSW0RD -I lan sdr: Command timed out. -

If i run the command ipmitool manually i got =

root@monitoring:/etc/telegraf# /usr/bin/ipmitool -H 10.16.100.64 -U USERID -P PASSW0RD -I lan sdr
SysBrd 3.3V | 3.32 Volts | ok
SysBrd 5V | 5.15 Volts | ok
SysBrd 12V | 12.14 Volts | ok
CMOS Battery | 3.14 Volts | ok
Avg Power | 270 Watts | ok
CPU Power | no reading | ns
DIMM Power | no reading | ns
Fan 1 Power | no reading | ns
Fan 2 Power | no reading | ns

here is my config =

#6

How to add the timeout and interval parameter on telegraf? i use telegraf for ubuntu, the binary file. i see the source from github using go, but i still cant make to compile it.

Regards,
RidhoYP

1 Like
#7

Its already solved,

using telgraf ipmi_sensor plugin

Thanks

1 Like