Kapacitor 1.4.0: TICK script autoloading from dir doesn't work

kapacitor
#1

Tick script loading - doesnt work. :frowning:
I’m using kapacitor 1.4.0 into docker container (with influx).
Kapacitor from:
https://dl.influxdata.com/kapacitor/releases/kapacitor-1.4.0.x86_64.rpm
Tick script dir from conf:
dir = "/etc/kapacitor/load"
In addition - env:
KAPACITOR_LOAD_DIR=/etc/kapacitor/load
Tick script directory rights - 755.

$ kapacitor list tasks
ID Type      Status    Executing Databases and Retention Policies

What is wrong?

Additional information:
Docker container - based at CentOs7 image.
System manager - s6-overlay.

#2

Do you have the load enabled config setting?

KAPACITOR_LOAD_ENABLED=true
#3

Yes, directly in kapacitor.conf:
[load]
enabled = true

#4

What is the structure of the directory /etc/kapacitor/load?

#5
$ ls /etc/kapacitor/load/
nodes.tick  replicas.tick
#6

Thats the issue. See the example directory for the intended structure of that directory.

Essentially it should have a subdirectory calls tasks where the tickscript can be placed.

1 Like
#7

Oh, sorry for long waitng.
It’s realy solution, many thanks!

1 Like