InfluxDB 2.0 Error: timeout & queue length exceeded

Good day.

I ran into the following error using InfluxDB v2.0.6 on Linux 64 bit:

After about 3 hours of load (read & write), I get errors on client side:

  • unexpected error writing points to database: timeout

Then, after a short while, I get errors:

  • Bad request: queue length exceeded

As a result, InfluxDB instance becomes unusable until I restart it.

Per advice from InfluxDB member, I set log level=debug and repeated my test. InfluxDB got stuck again. As far as I can see, there is no DIRECT indication of the error in the log file.

What I noticed in the log file was, that this particular message: msg=Deleted log_id=... stops appearing around the same time when I start getting timeout errors on client side. From the looks of it, queue processing somehow gets stuck in InfluxDB, resulting first in timeout erros and then queue length exceeded errors shortly after.

Can someone please try to help?

I can provide the log file from InfluxDB with level=debug though the file pretty large: it occupies 155 MB of space because I run my load test for 3 hours before the error starts appearing.

One more thing I noticed is that there is a recent message on the forum from 12d ago mentioning a similar error: timeout appearing under load. Influxdb v2.0 error This makes me wonder if the problem is widespread and not isolated to just my particular use case?