Help : Influx 1.8.10 on RaspPi 2B (Debian 11 Bullseye)

Hey,

I can’t get Grafana 9.1.3 to connect to Influx 1.8.10 using InfluxQL using Debian 11 on a RaspPi 2B (32bit).

This tutorial (Installing InfluxDB & Grafana on Raspberry Pi) has not worked for me. I freshly flashed Raspbian, updated it and followed the tutorial carefully, no errors installing or adding the database or user. When adding the data source in Grafana GUI, Grafana just says “error connecting influxDB influxQL” despite influx journal log showing a happy response.

“Sep 07 23:27:57 raspberrypi influxd-systemd-start.sh[27843]: [httpd] ::1 - grafana [07/Sep/2022:23:27:57 +0100] “GET /query?db=home&epoch=ms&q=SHOW+measurements HTTP/1.1” 200 57 “-” “Grafana” 52e63eda-2efc-11ed-8008-b827eb54111f 5427”

I tried setting Influx to Flux mode instead in the .conf, but then influx just will not start.

Sep 07 23:04:33 raspberrypi influxd-systemd-start.sh[27024]: InfluxDB API unavailable after 62 attempts…
Sep 07 23:04:34 raspberrypi influxd-systemd-start.sh[27024]: InfluxDB API unavailable after 63 attempts…

I even tried modifying the influxd-systemd-start.sh to give it 30 seconds before retrying, and no luck.

Is Influx 1.8 just dead now? Any tricks I should know to overcome this ? or should I just give up already use a 64bit OS and Influx 2 ?

All I want to do is take some mqtt data and graph it.

I had the same problem 2 days ago
Grafana 9.1.3 to connect to Influx 1.8.10 in Windows Server 2016
I re install Grafana 9.0.8 : OK
→ I think that th DB is empty
When I insert in Grafana a new Influx DB th system is ok

I don’t know where is the problem, but I ask to Grafana Forum.

Yes, working on Grafana 9.0.8. Nice one. Can you link here the Grafana forum / bug report.

1 Like