Float not stored

Hi
I successful store Icinga performance data in InfluxDB. A Instert contains values in ranges from 0 to 1.0E-8
Now, the values are stored successful if the values biger than 1.0E-5. Smaler than 1.0E-5 the values are stored as 0
Is this a InfluxDB limitation?
Is there a setting to check, or to change?
something i missed here? sorry for that!
BR A

Hi
I successful store Icinga performance data in InfluxDB.

Is that version 1.x or 2.0?

A Insert contains values in ranges from 0 to 1.0E-8

So, that means your range is positive values smaller than 0.000 000 01

Now, the values are stored successful if the values above 1.0E-5.

Eh?

That would be 0.000 01, which is way bigger than the range you mentioned
above.

Below 1.0E-5 the values are stored as 0 Is this a InfluxDB limitation?

I don’t see that it would be. According to the documentation
https://v2.docs.influxdata.com/v2.0/reference/flux/language/types/ floats are 64-
bit IEEE 754 values, so https://en.wikipedia.org/wiki/IEEE_754 you should be
able to store 15 (decimal) digits of precision, with an exponent anywhere
between -300 and +300.

Maybe you could give us more details of the format of values you’re trying to
store, the method you’re using to retreive them, and anything else which might
help us understand what’s happening.

Regards,

Antony.

Sorry for the miss wording about above and below! … was late… i corrected my first post

Version - quite old: 0.10 - upstream on ubuntu 16.04
According to your link, with 64bit float it should work.
I don’t know, is there a possibility, to check the settings of the influx Schema? If its 32 or 64 bit?

The Format is in scientific notation - 1.39E-5
I store the data from Icinga monitoring to InfluxDB - i have to check, the write process first!
Grafana is used to retreive the data.