"failed to determine if instance has been configured"

Hi Ma’am/Sir,

I am new to Influxdb. So please pardon me if am asking a very basic stuff. Actually I couldn’t find any help regarding this anywhere. I have installed Influxdb OSS V 2.0 recently on my Windows 10 OS run machine. In the command prompt, I am able to run the daemon CLI command “influxd” which returns the details but “influx setup” returns a configuration Error from which I have pasted an extract as the subject. The complete statement as displayed on the cmd prompt is:

Error: failed to determine if instance has been configured: Get “http://localhost:8086/api/v2/setup”: dial tcp [::1]:8086: connectex: No connection could be made because the target machine actively refused it.
See ‘influx setup -h’ for help

Please check and guide. I have checked many blogs and YouTube videos as much as I could with my limited knowledge.


1 Like

I haven’t seen this error yet in community. When you start influxd normally, can you curl http://localhost:8086/ping successfully from your machine?
What machine are you running InfluxDB on?

Hi Anaisdg,

I run Influxd so it gave the follows:

C:\Program Files\Influx\influxdb2-2.0.7-windows-amd64>influxd
2021-08-04T08:44:28.045897Z info Welcome to InfluxDB {“log_id”: “0Vl5D23G000”, “version”: “2.0.7”, “commit”: “2a45f0c037”, “build_date”: “2021-06-04T19:17:40Z”}
2021-08-04T08:44:28.097885Z info Resources opened {“log_id”: “0Vl5D23G000”, “service”: “bolt”, “path”: “C:\Users\ashok\.influxdbv2\influxd.bolt”}
2021-08-04T08:44:28.398506Z info Using data dir {“log_id”: “0Vl5D23G000”, “service”: “storage-engine”, “service”: “store”, “path”: “C:\Users\ashok\.influxdbv2\engine\data”}
2021-08-04T08:44:28.398506Z info Compaction settings {“log_id”: “0Vl5D23G000”, “service”: “storage-engine”, “service”: “store”, “max_concurrent_compactions”: 2, “throughput_bytes_per_second”: 50331648, “throughput_bytes_per_second_burst”: 50331648}
2021-08-04T08:44:28.399503Z info Open store (start) {“log_id”: “0Vl5D23G000”, “service”: “storage-engine”, “service”: “store”, “op_name”: “tsdb_open”, “op_event”: “start”}
2021-08-04T08:44:28.399503Z info Open store (end) {“log_id”: “0Vl5D23G000”, “service”: “storage-engine”, “service”: “store”, “op_name”: “tsdb_open”, “op_event”: “end”, “op_elapsed”: “0.000ms”}
2021-08-04T08:44:28.399503Z info Starting retention policy enforcement service {“log_id”: “0Vl5D23G000”, “service”: “retention”, “check_interval”: “30m”}
2021-08-04T08:44:28.399503Z info Starting precreation service {“log_id”: “0Vl5D23G000”, “service”: “shard-precreation”, “check_interval”: “10m”, “advance_period”: “30m”}
2021-08-04T08:44:28.399503Z info Starting query controller {“log_id”: “0Vl5D23G000”, “service”: “storage-reads”, “concurrency_quota”: 1024, “initial_memory_bytes_quota_per_query”: 9223372036854775807, “memory_bytes_quota_per_query”: 9223372036854775807, “max_memory_bytes”: 0, “queue_size”: 1024}
2021-08-04T08:44:28.403492Z info Configuring InfluxQL statement executor (zeros indicate unlimited). {“log_id”: “0Vl5D23G000”, “max_select_point”: 0, “max_select_series”: 0, “max_select_buckets”: 0}
2021-08-04T08:44:28.858887Z info Starting {“log_id”: “0Vl5D23G000”, “service”: “telemetry”, “interval”: “8h”}
2021-08-04T08:44:28.859886Z info Listening {“log_id”: “0Vl5D23G000”, “service”: “tcp-listener”, “transport”: “http”, “addr”: “:8086”, “port”: 8086}
2021-08-04T09:14:28.404886Z info Retention policy deletion check (start) {“log_id”: “0Vl5D23G000”, “service”: “retention”, “op_name”: “retention_delete_check”, “op_event”: “start”}
2021-08-04T09:14:28.415858Z info Retention policy deletion check (end) {“log_id”: “0Vl5D23G000”, “service”: “retention”, “op_name”: “retention_delete_check”, “op_event”: “end”, “op_elapsed”: “10.972ms”}

Then I opened another cmd prompt window and did:

C:\Program Files\Influx\influxdb2-2.0.7-windows-amd64>curl http://localhost:8086/ping

C:\Program Files\Influx\influxdb2-2.0.7-windows-amd64>

So the prompt returned when I run curl command with the argument you mentioned. Otherwise if I run that curl command prior to running influxd command it would display Connection Refused Error and move to the next prompt.

Please guide. I understand these are basics but since I can’t find a suitable documentation or tutorial for this issue am asking.