Error in uploading CSV file

Hello Everyone,
I am Giuseppe , I am going to use Influxdb to make a Database.
I have many files in CSV but I cannot upload them on my bucket .
I keep getting this error: Failed to upload the selected CSV: error in csv.from(): failed to read metadata: missing expected annotation datatype

I got the same issue. It looks UI offers to drop (or point to) annotated file. However, there is no placeholder for dropping or pointing to regular CSV file. Seems to be the simplest thing you would like to do in order to get sense of Influx, but it is not there for some reason. It raises the essential question - is it worth trying further?

Dear Victor ,
I solved my problem with LIne protocol.
I uploaded my file influx.
Try this format : jan21,sensorID=Le21 mag=15.11,date=20210105,time=185547000

G-U, Thank you for reply!
However, it sounds you re-formatted your file.
I am still curios why plain CSV (saved from Excel) is not supported.
It is kind of “standard” and UI seems to have this option.
I can do it with one file, but if I have dozens I have to pass each file though some transformation.

Dear Victor ,
I work on Linux. I do not know about CSV (saved from Excel) .
On Linux is easier , because you can change the format of your file, for example : txt in csv
Try to follow that format that I mentioned before.
In case, there are a lot of websites to convert your file CSV To Excel/Delimited Converter
look this Writing and Querying Data | Time to Awesome
but I am not an expert , I am trying to do a database. I hope that all things above could help you
I

I get the same error “Failed to upload the selected CSV: error in csv.from(): failed to read metadata: missing expected annotation datatype”. I’ve tried amending the annotation headers many times but then I realized that I even get the error when trying to upload the CSV samples from the InfluxDB documentation! I’m running InfluxDB locally in a Docker container. I use the method: Data > Buckets > Add Data > CSV Upload, then select the local csv file.
Any help would be appreciated

@Geoff_R
Which InfluxDB version are you using?
Can you post a sample snippet of the csv file here? The first lines are enough, possibly sensitive data can be replaced.

Hi,

I am getting the same error. I am using InfluxDB UI on Windows OS.
Here is the snippet from my csv file.

Any helpful leads would be much appreciated.

Cheers!