Data stops at 2147483647 for influxdb 1.6.1

Hi there I wrote some software for that sends data from COLLECTD via csv translation to influxdb. it was working fine. but I update to the newer influxdb 1.6.1 I believe is the version . now my data stops at 2147483647 . where as before it would work fine

the csv format is in this format
2018-08-16 22:02:02,578527857,12037843403
2018-08-16 22:02:04,578544624,12037863603
2018-08-16 22:02:06,578558537,12037936331
2018-08-16 22:02:08,578572678,12038036270
2018-08-16 22:02:10,578601072,12038122814
2018-08-16 22:02:12,578603045,12038132742
2018-08-16 22:02:14,578612452,12038157792
2018-08-16 22:02:16,578633138,12038234190
2018-08-16 22:02:18,578646436,12038309756
2018-08-16 22:02:20,578682513,12038339027
2018-08-16 22:02:22,578718635,12038762544
2018-08-16 22:02:24,578759599,12039210691
2018-08-16 22:02:26,578849135,12039818146
2018-08-16 22:02:28,578900611,12040861576

if I restart the counter it works fine again until 2147483647 is reached again

but what I find weird is if I send single values it goes past 2147483647 I tried up to 30 digits without problems example:
timestamp, value
2018-08-16 22:02:02,57852785712037843403
2018-08-16 22:02:04,57854462412037863603
2018-08-16 22:02:06,57855853712037936331
2018-08-16 22:02:08,57857267812038036270
2018-08-16 22:02:10,578601072,12038122814
2018-08-16 22:02:12,57860304512038132742
2018-08-16 22:02:14,57861245212038157792
2018-08-16 22:02:16,57863313812038234190
2018-08-16 22:02:18,57864643612038309756
2018-08-16 22:02:20,57868251312038339027
2018-08-16 22:02:22,57871863512038762544
2018-08-16 22:02:24,57875959912039210691
2018-08-16 22:02:26,57884913512039818146
2018-08-16 22:02:28,57890061112040861576

it just when i send 2 or more values are sent at once when it stops working… it use to work fine on previous version just this new version it is not ( not sure what version the previos was but it was downloaded fast fall 1.5.x I suspect )

i tried both windows and linux version of influxdb same issue…

does any one know how to resolve this issue

how does one download a previous versions of influxdb as a work around as I can not seam to locate links for it

2147483647 is the largest 32-bit signed integer. Any chance you downloaded the 32-bit build?

not that I know of it a 64bit ubuntu (uname -a > x86_64) how does one tell the arch of influxdb I though it was all 64 bit now when i apt-cache search it only list it a influx no arch type listed

but for single values sends i do not run into the limit only when I do a multi value input

Try running file /usr/bin/influxd to double check, but this seems like you found a bug to me, even if it is the 32-bit build. Can you report this issue on github?

okay I reported issue

do you know of a software repository that i use to get older version for now until new version is sorted. all I find is source code for older version

well I see I can make csv work around by adding a decimal point to the number then it process it with out problem

If you modify the version in the links from the download page you can still access older versions: