1m interval metrics have timestamp 10 seconds later

Metrics arrive form telegraf to the influxdb with every minute, but start from +10 seconds.
Screenshot_5

How can I fix the timestamp to the beginning of each minute?
The input that collects metrics is a kafka consumer.
Thank you.

Can you post the [agent] section of your telegraf config file?

```toml
[agent]
your agent configs here...
```
[agent]
  ## Default data collection interval for all inputs
  interval = "60s"
  round_interval = true
  metric_batch_size = 1000
  metric_buffer_limit = 10000
  collection_jitter = "0s"
  flush_interval = "10s"
  flush_jitter = "0s"
  precision = ""
  hostname = ""
  omit_hostname = false








I don’t know how Telegraf works internally and if this is even possible, but you could try with:

interval = "1m"

I assume that the Kafka Input plugin already sets the timestamp?
Otherwise the flush_interval could of course also be the problem.

I have tried setting the interval to “1m” but nothing changes.

When I inspect the influx data in table format, I see that indeed the _time field is always +10s.

All inputs from all plugins have that +10s. Isn’t the telegraf supposed to run every exact minute? (The machine’s clock is correctly synced)