# Problem configuring Telegraf

**URL:** https://community.influxdata.com/t/problem-configuring-telegraf/14092
**Category:** Welcome & Getting Started
**Tags:** telegraf
**Created:** [April 28, 2020, 9:50pm UTC](https://community.influxdata.com/t/problem-configuring-telegraf/14092 "2020-04-28T21:50:34Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![klulue](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/klulue/32/4830_2.png) [@klulue](https://community.influxdata.com/u/klulue)
#### Post date: [April 28, 2020, 9:50pm UTC](https://community.influxdata.com/t/problem-configuring-telegraf/14092/1 "2020-04-28T21:50:34Z")

</div>

I have spent the last 4/5 days installing the TICK stack (also with Grafana sometimes) on many machines. I have followed a number of different walk-throughs and I am stuck. The Basic config I can get and I have even been able to install Telegraf on a Windows machine and have it sending some basic information over to my CentOS machine and it shows as a host in Chronograf.

The problem I have is when I try to add anything extra to my telegraf.conf file, I can’t start the service. I am trying to monitor my network with SNMP. I followed [Unifi APs in Grafana using SNMP – The Cruft Of My Brain](https://thecruftofmybrain.com/?p=673) for Unifi into telegraf and downloaded the Grafana dashboard, but when I place the [[inputs.snmp]], I can add that line, but if I add any combination of any other lines, I get the following:

● telegraf.service - The plugin-driven server agent for reporting metrics into InfluxDB  
Loaded: loaded (/usr/lib/systemd/system/telegraf.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2020-04-28 16:25:43 CDT; 1s ago  
Docs: [GitHub - influxdata/telegraf: The plugin-driven server agent for collecting & reporting metrics.](https://github.com/influxdata/telegraf)  
Process: 6029 ExecStart=/usr/bin/telegraf -config /etc/telegraf/telegraf.conf -config-directory /etc/telegraf/telegraf.d $TELEGRAF\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 6029 (code=exited, status=1/FAILURE)

Apr 28 16:25:43 nms.lulue.int systemd[1]: telegraf.service: Service RestartSec=100ms expired, scheduling restart.  
Apr 28 16:25:43 nms.lulue.int systemd[1]: telegraf.service: Scheduled restart job, restart counter is at 5.  
Apr 28 16:25:43 nms.lulue.int systemd[1]: Stopped The plugin-driven server agent for reporting metrics into InfluxDB.  
Apr 28 16:25:43 nms.lulue.int systemd[1]: telegraf.service: Start request repeated too quickly.  
Apr 28 16:25:43 nms.lulue.int systemd[1]: telegraf.service: Failed with result ‘exit-code’.  
Apr 28 16:25:43 nms.lulue.int systemd[1]: Failed to start The plugin-driven server agent for reporting metrics into InfluxDB.

---

<div class="post-metadata">

### Author: ![klulue](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/klulue/32/4830_2.png) [@klulue](https://community.influxdata.com/u/klulue)
#### Post date: [April 29, 2020, 3:15am UTC](https://community.influxdata.com/t/problem-configuring-telegraf/14092/2 "2020-04-29T03:15:35Z")

</div>

I think I finally found out what was going on. It seems that the items that I was copying did not line up the text correctly and I did not realize it. I was doing a copy paste and it would not allow Telegraf to start.
