No CLI after installing InfluxDB on Raspberry PI

I am having issues installing InfluxDB on Raspberry PI running Rasbian Lite. I followed the instructions for a Debian installation. There are no errors during the installation and the service starts without a problem. However the CLI does not appear to be available. The command influx returns a “command not found” error. It is also not found in /usr/bin (though influxd is).

I tried the installation twice yesterday (even reinstalled the OS) and had the same problem both times. However, I thought I would try again this morning. After looking at the Debian installation instructions for 1.3, I noticed the following line that was not present in the 1.4 instructions

test $VERSION_ID = “9” && echo “deb https://repos.influxdata.com/debian stretch stable” | sudo tee /etc/apt/sources.list.d/influxdb.list

After including this line, the “influx” command now works.

1 Like

I have a Raspberry Pi running Debian stretch. The proposed solution does not work for me. I have tried versions 1.0.2 and 1.7.7. Many of the web sites with the instructions are clearly out of date. I can launch influxdb service but I get “command not found” for either of the following:

influx
Influxd

My understanding is that I must run the CLI via ‘influx’ in order to create a database, so I cannot proceed without the CLI.

You installed influxdb from the default repository. Try:

apt remove influxdb
curl -sL https://repos.influxdata.com/influxdb.key | sudo apt-key add -
lsb_release -a
echo “deb https://repos.influxdata.com/ubuntu stretch stable” | sudo tee /etc/apt/sources.list.d/influxdb.list
apt update
apt install influxdb
systemctl unmask influxdb.service
service influxdb start
influx

I have this issue aswell.
run: open server: listen: listen tcp 127.0.0.1:8088: bind: address already in use
pi@raspberrypi:/bin $ influx
bash: influx: command not found

pi@raspberrypi:/bin $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster

Also the advice given above returns for the first line:
pi@raspberrypi:/ $ apt remove influxdb
E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/influxdb.list
E: The list of sources could not be read.
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

I just had the same issue, and through looking at the above comments I figured out my problem.
I’m using Buster, not Stretch, so I made a change to what was provided by joustik

sudo apt remove influxdb
curl -sL https://repose.influxdata.com/finluxdb.key | sudo apt-key add -
sudo lsb_release-a
echo "deb https://repos.influxdata.com/ubuntu buster" | sudo tee /etc/apt/sources.list.d/influxdb.list
sudo apt update
# I ran into a problem with the masking when I did the install, so I ended up installing, unmasking, and installing again, but you might not need to if you unmask first. I don't know
sudo apt install influxdb
sudo systemctl unmask influxdb.service
sudo apt install influxdb

From here I did the rest of the setup instructions I saw online:

influx -config /etc/influxdb/influxdb.conf
sudo nano /ect/influxdb/influxdb.conf # to uncomment some https settings
sudo service influxdb restart
influx

and I happily ended up connected!

I just did:
sudo apt install influxdb
sudo apt install influxdb-client

:slight_smile:

1 Like

yes, that also worked for me.