No available host error when Querying multiple data points

Dear influx Experts,

I set up node-red as the one who writes data into influxdb instance, I am writing datapoints every 5ms (milliseconds) using node-red-contrib-influxdb . and I set up grafana to view my data.
I found no problem when querying last 1hour,30mins, 15mins and 5mins in grafana side, node-red can still write data.

I already run my influxdb instance for almost a month, so from grafana I tried to query data for my last 7 days, what happens is, nodered is giving me an error of “No host available”, it’s kinda cannot connect to my influxdb instance. The query from grafana takes a little bit of 7 secs, and when the query stop, the node-red can write to data now.

Is it something to do with my configuration with InfluxDB? I’ve already set all max-query, max-connections and my configuration to be limitless. It’s like Influx cannot accommodate request of querying and at the same time writing.

I hope you can help me guys.

Thank you very much.

WIth kind regards,

Might be worth including your actual influxdb config file inside a code block </> , and redact any passwords or identifying info. Add notes for what was used originally, and what your changed during each test.

It doesnt make sense to me why a query would block new data writes. Pls include version your using too

Hello fixTestRepeat,

Thanks for replying ! :slight_smile: Highly appreciated your concern in here.
My configs are all in a default settings,I just uncomment the max-query, max-connections and set it to zero (I do believe the defaults are zero too). everything is on the default mode.

Upon researching, I’ve seen other people to write data to influxDB in a “batch” method.
My current system writes every (5ms) and 10 connections to influxDB writing at that speed (5ms). One of their recommendation so to not leak “memory” or the “performance” of influxDB is to write multiple data points at the same time radther than writing it at very high speed. (there is a blog regarding here on how to maximize performance on writing to influxDB).

So basically, I found a way to do that, instead of writing at very high speed, I tried to write multiple data at a time. It seems like the performance looks good as it is. I just need to run my system (1 week again), and try to query the last 7 days in grafana and see if there we’re having to issues. (I hope there is none :slight_smile: )

Anyways, again I appreciate your response. I will get back here after a week and let the community know the probably solutions when they encounter such problem.



1 Like