# Max-series-per-database limit exceeded 1000000, error question

**URL:** <https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273>\
**Category:** InfluxDB 2\
**Tags:** influxdb, telegraf, time-series, grafana\
**Created:** [December 9, 2019, 3:51pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273 "2019-12-09T15:51:21Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tyler\_D](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/tyler_d/32/3916_2.png) [@Tyler\_D](https://community.influxdata.com/u/Tyler_D)\
**Post date:** [December 9, 2019, 3:51pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273/1 "2019-12-09T15:51:21Z")

</div>

Hey, so I got this error and did what the doc files suggested, setting max-series-per-database limit exceeded = 0 for unlimited number of series per database.

This resolved this issue, but my question is, does that now consume alot more disk space on the instance that holds the influxdb? What are the retention policies regarding that? Just want to understand this a bit better, thank you

---

<div class="post-metadata">

**Author:** ![Anaisdg](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/anaisdg/32/6401_2.png) [@Anaisdg](https://community.influxdata.com/u/Anaisdg)\
**Post date:** [December 9, 2019, 6:19pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273/2 "2019-12-09T18:19:39Z")

</div>

@Tyler_D,  
Thanks for your question. The max-series-per-database limit exists only in the `inmem` index (the default in 1.x). It exists because the `inmem` index can cause the server to OOM if too many series are added to the index. Since it’s rebuilt on startup, and OOMing server can continue to OOM when it restarts, making it operationally difficult to sort out the cardinality problem. The limit was determined based on general query performance at the limit along with heap usage with typical HW. You might want to look into enabling [TSI](https://docs.influxdata.com/influxdb/v1.7/concepts/time-series-index/) if you haven’t already and you’re dealing with that type of cardinality (it’s the default in 1.7.x +).

---

<div class="post-metadata">

**Author:** ![Tyler\_D](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/tyler_d/32/3916_2.png) [@Tyler\_D](https://community.influxdata.com/u/Tyler_D)\
**Post date:** [December 11, 2019, 4:39pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273/3 "2019-12-11T16:39:39Z")

</div>

Just to clarify,

lets say I keep the mac-series-per-database set to 0, as mentioned in the grafana docs, what would happen down the road. Would it eventually consume and affect disk usage?

With regards to what you said, as I am new, OOM and HW mean what?

---

<div class="post-metadata">

**Author:** ![Mert](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/mert/32/5152_2.png) [@Mert](https://community.influxdata.com/u/Mert)\
**Post date:** [December 14, 2019, 4:05pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273/4 "2019-12-14T16:05:37Z")

</div>

@Tyler_D  
HW: Hardware.  
OOM: Out of memory.

---

<div class="post-metadata">

**Author:** ![Anaisdg](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/anaisdg/32/6401_2.png) [@Anaisdg](https://community.influxdata.com/u/Anaisdg)\
**Post date:** [December 16, 2019, 10:07pm UTC](https://community.influxdata.com/t/max-series-per-database-limit-exceeded-1000000-error-question/12273/5 "2019-12-16T22:07:04Z")

</div>

It could potentially affect mem. But you need REALLY high cardinality for that. Most OSS users don’t have any problem (esp after enabling TSI).
