# InfluxDB 2 / Telegraf "authorization not found" \[Docker/Windows\]

**URL:** <https://community.influxdata.com/t/influxdb-2-telegraf-authorization-not-found-docker-windows/19468>\
**Category:** InfluxDB 2\
**Tags:** telegraf, windows, docker\
**Created:** [April 19, 2021, 12:59pm UTC](https://community.influxdata.com/t/influxdb-2-telegraf-authorization-not-found-docker-windows/19468 "2021-04-19T12:59:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Flint](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/flint/32/7240_2.png) [@Flint](https://community.influxdata.com/u/Flint)\
**Post date:** [April 19, 2021, 12:59pm UTC](https://community.influxdata.com/t/influxdb-2-telegraf-authorization-not-found-docker-windows/19468/1 "2021-04-19T12:59:57Z")

</div>

Hi!

I’m fairly new to influx & telegraf and am trying to get all of this working on windows.  
I’ve installed influxdb 2.0.4 on docker and the latest telegraf “seperately” on windows.

**Setup**  
In the meantime I’ve managed to reach the influx UI in my chrome browser.  
With this I’ve created a token with read/write permission to a newly created bucket.

For telegraf I’ve edited the config to include the necessary details (through the influx UI with “InfluxDB Output Plugin”). I’ve removed all other inputs [and manually added](https://docs.influxdata.com/influxdb/v2.0/write-data/no-code/use-telegraf/manual-config/?t=Windows) the ‘[ping](https://github.com/influxdata/telegraf/blob/release-1.18/plugins/inputs/ping/README.md)’ config pointing to a local server:

```
# Telegraf Configuration
#
# Telegraf is entirely plugin driven. All metrics are gathered from the
# declared inputs, and sent to the declared outputs.
#
# Plugins must be declared in here to be active.
# To deactivate a plugin, comment out the name and any variables.
#
# Use 'telegraf -config telegraf.conf -test' to see what metrics a config
# file would generate.
#
# Environment variables can be used anywhere in this config file, simply surround
# them with ${}. For strings the variable must be within quotes (ie, "${STR_VAR}"),
# for numbers and booleans they should be plain (ie, ${INT_VAR}, ${BOOL_VAR})

# Global tags can be specified here in key="value" format.
[global_tags]
  # dc = "us-east-1" # will tag all metrics with dc=us-east-1
  # rack = "1a"
  ## Environment variables can be used as tags, and throughout the config file
  # user = "$USER"

# Configuration for telegraf agent
[agent]
  ## Default data collection interval for all inputs
  interval = "10s"
  ## Rounds collection interval to 'interval'
  ## ie, if interval="10s" then always collect on :00, :10, :20, etc.
  round_interval = true

  ## Telegraf will send metrics to outputs in batches of at most
  ## metric_batch_size metrics.
  ## This controls the size of writes that Telegraf sends to output plugins.
  metric_batch_size = 1000

  ## Maximum number of unwritten metrics per output. Increasing this value
  ## allows for longer periods of output downtime without dropping metrics at the
  ## cost of higher maximum memory usage.
  metric_buffer_limit = 10000

  ## Collection jitter is used to jitter the collection by a random amount.
  ## Each plugin will sleep for a random time within jitter before collecting.
  ## This can be used to avoid many plugins querying things like sysfs at the
  ## same time, which can have a measurable effect on the system.
  collection_jitter = "0s"

  ## Default flushing interval for all outputs. Maximum flush_interval will be
  ## flush_interval + flush_jitter
  flush_interval = "10s"
  ## Jitter the flush interval by a random amount. This is primarily to avoid
  ## large write spikes for users running a large number of telegraf instances.
  ## ie, a jitter of 5s and interval 10s means flushes will happen every 10-15s
  flush_jitter = "0s"

  ## By default or when set to "0s", precision will be set to the same
  ## timestamp order as the collection interval, with the maximum being 1s.
  ## ie, when interval = "10s", precision will be "1s"
  ## when interval = "250ms", precision will be "1ms"
  ## Precision will NOT be used for service inputs. It is up to each individual
  ## service input to set the timestamp at the appropriate precision.
  ## Valid time units are "ns", "us" (or "µs"), "ms", "s".
  precision = ""

  ## Log at debug level.
  debug = true
  ## Log only error level messages.
  quiet = false

  ## Log target controls the destination for logs and can be one of "file",
  ## "stderr" or, on Windows, "eventlog". When set to "file", the output file
  ## is determined by the "logfile" setting.
  logtarget = "file"

  ## Name of the file to be logged to when using the "file" logtarget. If set to
  ## the empty string then logs are written to stderr.
  logfile = "telegrafLogs"

  ## The logfile will be rotated after the time interval specified. When set
  ## to 0 no time based rotation is performed. Logs are rotated only when
  ## written to, if there is no log activity rotation may be delayed.
  # logfile_rotation_interval = "0d"

  ## The logfile will be rotated when it becomes larger than the specified
  ## size. When set to 0 no size based rotation is performed.
  # logfile_rotation_max_size = "0MB"

  ## Maximum number of rotated archives to keep, any older logs are deleted.
  ## If set to -1, no archives are removed.
  # logfile_rotation_max_archives = 5

  ## Override default hostname, if empty use os.Hostname()
  hostname = ""
  ## If set to true, do no set the "host" tag in the telegraf agent.
  omit_hostname = false

###############################################################################
# OUTPUT PLUGINS #
###############################################################################

# Configuration for sending metrics to InfluxDB
# [[outputs.influxdb]]
  ## The full HTTP or UDP URL for your InfluxDB instance.
  ##
  ## Multiple URLs can be specified for a single cluster, only ONE of the
  ## urls will be written to each interval.
  # urls = ["unix:///var/run/influxdb.sock"]
  # urls = ["udp://127.0.0.1:8089"]
  # urls = ["http://127.0.0.1:8086"]

  ## The target database for metrics; will be created as needed.
  ## For UDP url endpoint database needs to be configured on server side.
  # database = "telegraf"

  ## The value of this tag will be used to determine the database. If this
  ## tag is not set the 'database' option is used as the default.
  # database_tag = ""

  ## If true, the 'database_tag' will not be included in the written metric.
  # exclude_database_tag = false

  ## If true, no CREATE DATABASE queries will be sent. Set to true when using
  ## Telegraf with a user without permissions to create databases or when the
  ## database already exists.
  # skip_database_creation = false

  ## Name of existing retention policy to write to. Empty string writes to
  ## the default retention policy. Only takes effect when using HTTP.
  # retention_policy = ""

  ## The value of this tag will be used to determine the retention policy. If this
  ## tag is not set the 'retention_policy' option is used as the default.
  # retention_policy_tag = ""

  ## If true, the 'retention_policy_tag' will not be included in the written metric.
  # exclude_retention_policy_tag = false

  ## Write consistency (clusters only), can be: "any", "one", "quorum", "all".
  ## Only takes effect when using HTTP.
  # write_consistency = "any"

  ## Timeout for HTTP messages.
  # timeout = "5s"

  ## HTTP Basic Auth
  # username = "telegraf"
  # password = "metricsmetricsmetricsmetrics"

  ## HTTP User-Agent
  # user_agent = "telegraf"

  ## UDP payload size is the maximum packet size to send.
  # udp_payload = "512B"

  ## Optional TLS Config for use on HTTP connections.
  # tls_ca = "/etc/telegraf/ca.pem"
  # tls_cert = "/etc/telegraf/cert.pem"
  # tls_key = "/etc/telegraf/key.pem"
  ## Use TLS but skip chain & host verification
  # insecure_skip_verify = false

  ## HTTP Proxy override, if unset values the standard proxy environment
  ## variables are consulted to determine which proxy, if any, should be used.
  # http_proxy = "http://corporate.proxy:3128"

  ## Additional HTTP headers
  # http_headers = {"X-Special-Header" = "Special-Value"}

  ## HTTP Content-Encoding for write request body, can be set to "gzip" to
  ## compress body or "identity" to apply no encoding.
  # content_encoding = "identity"

  ## When true, Telegraf will output unsigned integers as unsigned values,
  ## i.e.: "42u". You will need a version of InfluxDB supporting unsigned
  ## integer values. Enabling this option will result in field type errors if
  ## existing data has been written.
  # influx_uint_support = false

# # Configuration for sending metrics to InfluxDB
 [[outputs.influxdb_v2]]
  ## The URLs of the InfluxDB cluster nodes.
  ##
  ## Multiple URLs can be specified for a single cluster, only ONE of the
  ## urls will be written to each interval.
  ## urls exp: http://127.0.0.1:8086
  urls = ["http://localhost:8086"]

  ## Token for authentication.
  token = "$INFLUX_TOKEN"

  ## Organization is the name of the organization you wish to write to; must exist.
  organization = "My Test Organization"

  ## Destination bucket to write into.
  bucket = "testdb_1"
#
# ## The value of this tag will be used to determine the bucket. If this
# ## tag is not set the 'bucket' option is used as the default.
# # bucket_tag = ""
#
# ## If true, the bucket tag will not be added to the metric.
# # exclude_bucket_tag = false
#
# ## Timeout for HTTP messages.
# # timeout = "5s"
#
# ## Additional HTTP headers
# # http_headers = {"X-Special-Header" = "Special-Value"}
#
# ## HTTP Proxy override, if unset values the standard proxy environment
# ## variables are consulted to determine which proxy, if any, should be used.
# # http_proxy = "http://corporate.proxy:3128"
#
# ## HTTP User-Agent
# # user_agent = "telegraf"
#
# ## Content-Encoding for write request body, can be set to "gzip" to
# ## compress body or "identity" to apply no encoding.
# # content_encoding = "gzip"
#
# ## Enable or disable uint support for writing uints influxdb 2.0.
# # influx_uint_support = false
#
# ## Optional TLS Config for use on HTTP connections.
# # tls_ca = "/etc/telegraf/ca.pem"
# # tls_cert = "/etc/telegraf/cert.pem"
# # tls_key = "/etc/telegraf/key.pem"
# ## Use TLS but skip chain & host verification
# # insecure_skip_verify = false

###############################################################################
# INPUT PLUGINS #
###############################################################################

[[inputs.ping]]
  ## Hosts to send ping packets to.
  urls = ["10.100.2.36"]

  ## Method used for sending pings, can be either "exec" or "native". When set
  ## to "exec" the systems ping command will be executed. When set to "native"
  ## the plugin will send pings directly.
  ##
  ## While the default is "exec" for backwards compatibility, new deployments
  ## are encouraged to use the "native" method for improved compatibility and
  ## performance.
  method = "native"

  ## Number of ping packets to send per interval. Corresponds to the "-c"
  ## option of the ping command.
  count = 2

  ## Time to wait between sending ping packets in seconds. Operates like the
  ## "-i" option of the ping command.
  ping_interval = 1.0

  ## If set, the time to wait for a ping response in seconds. Operates like
  ## the "-W" option of the ping command.
  timeout = 3.0

  ## If set, the total ping deadline, in seconds. Operates like the -w option
  ## of the ping command.
  # deadline = 10

  ## Interface or source address to send ping from. Operates like the -I or -S
  ## option of the ping command.
  # interface = ""

  ## Percentiles to calculate. This only works with the native method.
  # percentiles = [50, 95, 99]

  ## Specify the ping executable binary.
  # binary = "ping"

  ## Arguments for ping command. When arguments is not empty, the command from
  ## the binary option will be used and other options (ping_interval, timeout,
  ## etc) will be ignored.
  # arguments = ["-c", "3"]

  ## Use only IPv6 addresses when resolving a hostname.
  # ipv6 = false

# # no configuration

```

Oh and I’ve assigned the INFLUX\_TOKEN ev with the newly created token mentioned above through [cmd](https://docs.influxdata.com/influxdb/v2.0/write-data/no-code/use-telegraf/manual-config/?t=Windows). At the moment I’ve confuged telegraf as a windows service which seems to be running.  
 ![image](https://us1.discourse-cdn.com/flex023/uploads/influxdata/original/2X/8/8e0e4be28b0be88e6221f8043279bb227546ed0c.png)

**Problem**  
Via docker’s Logs on my influxdb container I keep getting the following error line each time telegraf does it’s thing every 10s:

```
ts=2021-04-19T12:53:51.723912Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:01.736049Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:11.742796Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:21.745119Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:31.759499Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:41.758019Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:54:51.765318Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:01.764073Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:11.769352Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:21.780970Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:31.790098Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:41.802213Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

ts=2021-04-19T12:55:51.807681Z lvl=info msg=Unauthorized log_id=0TbU2Hs0000 error="authorization not found"

```

Then, when checking back in the influx UI in the “Data Explorer” I (obviously?) see no data after selecting my custom created bucket.  
 ![image](https://us1.discourse-cdn.com/flex023/uploads/influxdata/original/2X/2/2ef86460a1ada4817b3ee4ccbccbb145d1b30c83.png)

I’ve tested a bunch of stuff and read through a lot of topics trying to figure this out with my lack of knowledge, but can’t seem to get any further.

Can anyone point out what I should change to get this working?

---

<div class="post-metadata">

**Author:** ![Flint](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/flint/32/7240_2.png) [@Flint](https://community.influxdata.com/u/Flint)\
**Post date:** [April 20, 2021, 7:14am UTC](https://community.influxdata.com/t/influxdb-2-telegraf-authorization-not-found-docker-windows/19468/2 "2021-04-20T07:14:20Z")

</div>

Ok, my mistake. Setting the $INFLUX\_TOKEN ev via a seperate cmd window was the culprit.  
I had to include it somehow in the same “session-window” as my configured telegraf windows service.

I solved it for now by putting it directly in the config file even though the docs suggest [otherwise](https://docs.influxdata.com/influxdb/v2.0/write-data/no-code/use-telegraf/manual-config/):

 ![image](https://us1.discourse-cdn.com/flex023/uploads/influxdata/original/2X/6/608923d44fc9915a4426d24dbb55931184f9626c.png)

I was going to ask in here about the best way of approaching this without storing it directly in the config file, but that’s probably going to need it’s own topic.
