# Influxdb 1.8.7 will not start

**URL:** <https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965>\
**Category:** InfluxDB 1\
**Created:** [July 29, 2021, 7:03pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965 "2021-07-29T19:03:52Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![john\_v](https://avatars.discourse-cdn.com/v4/letter/j/3be4f8/32.png) [@john\_v](https://community.influxdata.com/u/john_v)\
**Post date:** [July 29, 2021, 7:03pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/1 "2021-07-29T19:03:52Z")

</div>

InfluxDB fails to start

`sudo systemctl start influxdb.service`

after installing:

`influxdb-1.8.7.x86_64.rpm from https://repos.influxdata.com/rhel/7/x86_64/stable/influxdb-1.8.7.x86_64.rpm`

…which seems to be last updated on **2021-07-28 21:09**

I get the following error when I run` journalctl -xe`

```auto
-- Unit influxdb.service has begun starting up.
Jul 29 18:53:05 my-machine-name systemd[19040]: Failed at step EXEC spawning /usr/lib/influxdb/scripts/influxd-systemd-start.sh: Permission denied

```

When I run the following command

`sudo chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh`

…then the service starts.

Looks like a packaging problem.

---

<div class="post-metadata">

**Author:** ![Panos\_G](https://avatars.discourse-cdn.com/v4/letter/p/87869e/32.png) [@Panos\_G](https://community.influxdata.com/u/Panos_G)\
**Post date:** [July 30, 2021, 2:48pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/2 "2021-07-30T14:48:04Z")

</div>

Hi new here(influxdb,Linux,raspberrypi etc). After update from 1.8.6-1 to 1.8.7-1 these a similar behaviour. i run `journalctl -u influxdb` and got these:

Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Service RestartSec=100ms expired, scheduling restart.  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Scheduled restart job, restart counter is at 3.  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: Stopped InfluxDB is an open-source, distributed, time series database.  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: Starting InfluxDB is an open-source, distributed, time series database…  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1551]: influxdb.service: Failed to execute command: Permission denied  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1551]: influxdb.service: Failed at step EXEC spawning /usr/lib/influxdb/scripts/influxd-systemd-start.sh: Permission denied  
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Control process exited, code=exited, status=203/EXEC

I got it run(partially ) only by sudo influxd.

---

<div class="post-metadata">

**Author:** ![john\_v](https://avatars.discourse-cdn.com/v4/letter/j/3be4f8/32.png) [@john\_v](https://community.influxdata.com/u/john_v)\
**Post date:** [July 30, 2021, 3:07pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/3 "2021-07-30T15:07:27Z")

</div>

The issue here is likely that the InfluxDB service is typically run as the user “influxdb”. If you want to confirm, you need to see where your systemd startup configuration is set. Not sure about the raspian distro, but on the RHEL that user is specific in /etc/systemd/system/influxd.service.

If the service doesn’t start for you, it could be that when the user influxdb can’t execute /usr/lib/influxdb/scripts/influxd-systemd-start.sh, the permissions issue I mentioned above. But, since you can run influxdb when you start with sudo seems to confirm you have the same issue.

---

<div class="post-metadata">

**Author:** ![Panos\_G](https://avatars.discourse-cdn.com/v4/letter/p/87869e/32.png) [@Panos\_G](https://community.influxdata.com/u/Panos_G)\
**Post date:** [July 30, 2021, 3:37pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/4 "2021-07-30T15:37:00Z")

</div>

it is the same path `/etc/systemd/system/influxd.service` and it is a symlink  
to /lib/systemd/system/influxdb.service

```auto
[Service]
User=influxdb
Group=influxdb
LimitNOFILE=65536
EnvironmentFile=-/etc/default/influxdb
ExecStart=/usr/lib/influxdb/scripts/influxd-systemd-start.sh
KillMode=control-group
Restart=on-failure
Type=forking
PIDFile=/var/lib/influxdb/influxd.pid

```

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [July 30, 2021, 4:19pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/5 "2021-07-30T16:19:13Z")

</div>

Ran into this bug today. running it on raspi also  
i chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh and services were able to be started  
upgraded info influxdb:armhf (1.8.6-1, 1.8.7-1)

---

<div class="post-metadata">

**Author:** ![aimdev](https://avatars.discourse-cdn.com/v4/letter/a/e95f7d/32.png) [@aimdev](https://community.influxdata.com/u/aimdev)\
**Post date:** [August 2, 2021, 6:24am UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/6 "2021-08-02T06:24:08Z")

</div>

Happened after the latest upgrade on Debian Buster, worked ok for months, so what has changed, and was it tested?

chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh  
worked, but not the correct solution(world r+x)

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 2, 2021, 1:18pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/7 "2021-08-02T13:18:14Z")

</div>

influx started failing again today. script is +x, so that’s not the issue now.  
this is getting frustrating

should I just move on to 2.x?

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 2, 2021, 1:22pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/8 "2021-08-02T13:22:19Z")

</div>

are there any instructions on downgrading? i’ll just move back to 1.8.6

---

<div class="post-metadata">

**Author:** ![john\_v](https://avatars.discourse-cdn.com/v4/letter/j/3be4f8/32.png) [@john\_v](https://community.influxdata.com/u/john_v)\
**Post date:** [August 2, 2021, 1:28pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/9 "2021-08-02T13:28:07Z")

</div>

v2 has some major changes that you need to test/consider before you upgrade to it.

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 2, 2021, 1:36pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/10 "2021-08-02T13:36:20Z")

</div>

yes…unfortunately, i may just have to do a fresh install and move to 2 maybe. i can’t find 1.8.6 in the repos…wish they’d just keep the old packages available.

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 2, 2021, 1:41pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/11 "2021-08-02T13:41:31Z")

</div>

started getting this error now, runtime: out of memory: cannot allocate 81920-byte block (1252196352 in use) fatal error: out of memory  
i’m not using inmem either. I have 4GB on my rasp pi, so I don’t think memory is really an issue. 1.8.7 has bugs

---

<div class="post-metadata">

**Author:** ![john\_v](https://avatars.discourse-cdn.com/v4/letter/j/3be4f8/32.png) [@john\_v](https://community.influxdata.com/u/john_v)\
**Post date:** [August 2, 2021, 1:41pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/12 "2021-08-02T13:41:31Z")

</div>

> [@aimdev](#):
>
> worked, but not the correct solution(world r+x)

@aimdev, you are correct: it’s certainly messy at best.

In my case the influxdb user is a member of only the group influxdb. Since the script under question is delivered with a ownership of root:root, I chose to “go wide.” Naturally, you could/should adjust any recommendation to match your implementation, as YMMV.

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 2, 2021, 2:51pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/13 "2021-08-02T14:51:11Z")

</div>

I have no idea what’s going on.  
I had rebooted my pi a few times and the service kept dying  
I was going to install 2.0, but wanted to enable 64 bit support on the pi, so I added the arm\_64bit=1  
to the /boot/config.txt file  
I restarted the pi and suddenly things are working just fine  
I’m thoroughly confused as to what’s going on now

---

<div class="post-metadata">

**Author:** ![john\_v](https://avatars.discourse-cdn.com/v4/letter/j/3be4f8/32.png) [@john\_v](https://community.influxdata.com/u/john_v)\
**Post date:** [August 2, 2021, 3:07pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/14 "2021-08-02T15:07:33Z")

</div>

@influxian - your out of memory error error sounds like a different issue - I’m not a rPi user of InfluxDB, so can’t comment there.

Perhaps spin up a new thread so that others can find it and comment on it?

---

<div class="post-metadata">

**Author:** ![codyshepherd](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/codyshepherd/32/7480_2.png) [@codyshepherd](https://community.influxdata.com/u/codyshepherd)\
**Post date:** [August 3, 2021, 6:37pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/15 "2021-08-03T18:37:35Z")

</div>

Hi there,

We are tracking the following two issues in 1.8.7 with the deb and rpm packages stemming from a wrapper script used for running in systemd:

> <https://github.com/influxdata/influxdb/issues/22004>
>
> Hello, 
> I had an influx database to manage sensors data in the building. I am a… complete beginner. Everything worked fine for 2 years. Today, after updating packages in raspbian and influx it does not work. I have messages: 
> Failed to connect to http://localhost:8086: Get http://localhost:8086/ping: dial tcp \[::1\]:8086: connect: connection refused
> Please check your connection settings and ensure 'influxd' is running.
> 
> After \`sudo systemctl start influxdb\` is
> Job for influxdb.service failed because the control process exited with error code.
> See "systemctl status influxdb.service" and "journalctl -xe" for details.
> 
> And after \`systemctl status influxdb.service\` i have:
> ● influxdb.service - InfluxDB is an open-source, distributed, time series database
> Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)
> Active: failed (Result: exit-code) since Sun 2021-08-01 23:11:23 CEST; 1min 12s ago
> Docs: https://docs.influxdata.com/influxdb/
> Process: 981 ExecStart=/usr/lib/influxdb/scripts/influxd-systemd-start.sh (code=exited, status=203/EXEC)
> 
> sie 01 23:11:23 raspberrypi systemd\[1\]: influxdb.service: Service RestartSec=100ms expired, scheduling restart.
> sie 01 23:11:23 raspberrypi systemd\[1\]: influxdb.service: Scheduled restart job, restart counter is at 5.
> sie 01 23:11:23 raspberrypi systemd\[1\]: Stopped InfluxDB is an open-source, distributed, time series database.
> sie 01 23:11:23 raspberrypi systemd\[1\]: influxdb.service: Start request repeated too quickly.
> sie 01 23:11:23 raspberrypi systemd\[1\]: influxdb.service: Failed with result 'exit-code'.
> sie 01 23:11:23 raspberrypi systemd\[1\]: Failed to start InfluxDB is an open-source, distributed, time series database.
> 
> What happend, can you help me?

> <https://github.com/influxdata/influxdb/issues/21967>
>
> \<!--
> 
> Thank you for reporting a bug in InfluxDB. 
> 
> \* Please ask usage questi…ons on the Influx Community site.
> \* https://community.influxdata.com/
> \* Please add a :+1: or comment on a similar existing bug report instead of opening a new one.
> \* https://github.com/influxdata/influxdb/issues?utf8=%E2%9C%93&q=is%3Aissue+is%3Aopen+is%3Aclosed+sort%3Aupdated-desc+label%3Akind%2Fbug+
> \* Please check whether the bug can be reproduced with the latest release.
> \* The fastest way to fix a bug is to open a Pull Request.
> \* https://github.com/influxdata/influxdb/pulls
> 
> \--\>
> 
> \_\_Actual behavior:\_\_
> 
> systemd service stuck in /usr/lib/influxdb/scripts/influxd-systemd-start.sh in while loop if http authentification is set
> I belive that problem is introduced in commit c8de72ddbc5fdf20f821ca473f1fdf92820f9ac3
> 
> \_\_Environment info:\_\_
> 
> \* System info: Linux 5.10.53-sunxi64 aarch64
> \* InfluxDB version: InfluxDB v1.8.7 (git: 1.8 v1.8.7)
> \* Other relevant environment details:
> dpkg -l | grep influx
> ii influxdb 1.8.7-1 arm64 Distributed time-series database.
> cat /etc/issue
> Ubuntu 18.04.5 LTS

Fixes are incoming (referenced in each respective bug) and we will be cutting a 1.8.8 release this week, with the recommended fix being to upgrade to the new version.

---

<div class="post-metadata">

**Author:** ![Panos\_G](https://avatars.discourse-cdn.com/v4/letter/p/87869e/32.png) [@Panos\_G](https://community.influxdata.com/u/Panos_G)\
**Post date:** [August 6, 2021, 1:35pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/16 "2021-08-06T13:35:42Z")

</div>

Hi,  
so i did update to 1.8.9 but still not able to run as a service. Now the status of the service is `inactive(dead)`.  
When i run influxd i get `run: open server: listen: listen tcp 127.0.0.1:8088: bind: address already in use`  
but i did not change something in my system since version 1.8.6 which was ok, again only with `sudo influxd`.

While reading another post, i tried to run `sudo systemctl start influxdb` and the service started!  
now the folder `/usr/lib/influxdb` is owned by root, should be change to influxd as suggested by the post below?

> [@Raspberry Pi 4 install issue](https://community.influxdata.com/t/raspberry-pi-4-install-issue/21025/8):
>
> Keeping those fingers crossed surely helped!! Ran this sudo systemctl start influxdb to finish the install tutorial got the same error: Job for influxdb.service failed because the control process exited with error code. See "systemctl status influxdb.service" and "journalctl -xe" for details. Ran the command sudo chown -R influxdb:influxdb /usr/lib/influxdb from the reddit post. Retried sudo systemctl start influxdb and got no error gringringrin InfluxDB is back up and running!! Wooo…

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 7, 2021, 4:53am UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/17 "2021-08-07T04:53:00Z")

</div>

still having issues in 1.8.9-1

> [@Raspberry Pi Influx issues (1.8.7-9)](https://community.influxdata.com/t/raspberry-pi-influx-issues-1-8-7-9/21099):
>
> well, since the 1.8.7-1 update things have gotten really frustrating on the Pi distros. I updated to the 1.8.7-1 and encountered the startup script issue and some random crashes with “out of memory”, but things settled down. i just updated to the 1.8.9-1 release and influx would not start. I was getting out of memory errors and also seg faults. I’m not using inmem, as that can cause out of memory issues. Since it wouldn’t start I decided to just rebuild the indexes completely. well, the ser…

---

<div class="post-metadata">

**Author:** ![bondskin](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/bondskin/32/8015_2.png) [@bondskin](https://community.influxdata.com/u/bondskin)\
**Post date:** [August 7, 2021, 8:57am UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/18 "2021-08-07T08:57:03Z")

</div>

I am also running 1.8.9-1 and influxdb is not able to start  
even with default configuration it does not come up  
pi@raspberrypidns:/etc/influxdb $ systemctl status influxdb.service  
● influxdb.service - InfluxDB is an open-source, distributed, time series database  
Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)  
Active: activating (start) since Sat 2021-08-07 10:56:20 CEST; 4s ago  
Docs: [InfluxDB OSS v2 Documentation](https://docs.influxdata.com/influxdb/)  
Cntrl PID: 17490 (influxd-systemd)  
Tasks: 20 (limit: 1891)  
CGroup: /system.slice/influxdb.service  
├─17490 /bin/bash -e /usr/lib/influxdb/scripts/influxd-systemd-start.sh  
├─17491 /usr/bin/influxd -config /etc/influxdb/influxdb.conf  
└─17540 sleep 1

Aug 07 10:56:20 raspberrypidns systemd[1]: Starting InfluxDB is an open-source, distributed, time series database…  
Aug 07 10:56:20 raspberrypidns influxd-systemd-start.sh[17490]: Merging with configuration at: /etc/influxdb/influxdb.conf  
Aug 07 10:56:20 raspberrypidns influxd-systemd-start.sh[17490]: Merging with configuration at: /etc/influxdb/influxdb.conf

## – Subject: A start job for unit influxdb.service has failed – Defined-By: systemd – Support: [Debian -- User Support](https://www.debian.org/support)

– A start job for unit influxdb.service has finished with a failure.

---

<div class="post-metadata">

**Author:** ![influxian](https://avatars.discourse-cdn.com/v4/letter/i/c57346/32.png) [@influxian](https://community.influxdata.com/u/influxian)\
**Post date:** [August 7, 2021, 12:03pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/19 "2021-08-07T12:03:02Z")

</div>

I spoke too soon. Service failed this morning and I haven’t looked into it, but I web’d into grafana and see Bad Gateway errors, which means influx is down, again.

Seriously, I may need to migrate to Prometheus or something else

---

<div class="post-metadata">

**Author:** ![steefan85](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/steefan85/32/8016_2.png) [@steefan85](https://community.influxdata.com/u/steefan85)\
**Post date:** [August 7, 2021, 12:43pm UTC](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965/20 "2021-08-07T12:43:13Z")

</div>

Same problem here. 1.8.9-1  
sudo systemctl start influxdb  
Job for influxdb.service failed because the control process exited with error code.  
See “systemctl status influxdb.service” and “journalctl -xe” for details.

sudo service influxdb status  
● influxdb.service - InfluxDB is an open-source, distributed, time series database  
Loaded: loaded (/lib/systemd/system/influxdb.service; disabled; vendor preset: enabled)  
Active: activating (start) since Sat 2021-08-07 14:40:29 CEST; 4s ago  
Docs: [InfluxDB OSS 2.6 Documentation](https://docs.influxdata.com/influxdb/)  
Cntrl PID: 27537 (influxd-systemd)  
Tasks: 14 (limit: 4915)  
CGroup: /system.slice/influxdb.service  
├─27537 /bin/bash -e /usr/lib/influxdb/scripts/influxd-systemd-start.sh  
├─27538 /usr/bin/influxd -config /etc/influxdb/influxdb.conf  
└─27585 sleep 1

Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.632481Z lvl=info msg="Ope  
Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.634698Z lvl=info msg="Ope  
Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.636942Z lvl=info msg="Ope

[Next page](https://community.influxdata.com/t/influxdb-1-8-7-will-not-start/20965.md?page=2)
