# HTTP enable Influxdb failed

**URL:** https://community.influxdata.com/t/http-enable-influxdb-failed/19088
**Category:** Systems
**Tags:** influxdb
**Created:** [March 26, 2021, 11:43am UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088 "2021-03-26T11:43:10Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 11:43am UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/1 "2021-03-26T11:43:10Z")

</div>

Hi guys, I followed the tutorial of the influx documentation to enable HTTP ([Enable HTTPS with InfluxDB | InfluxDB OSS 1.8 Documentation](https://docs.influxdata.com/influxdb/v1.8/administration/https_setup/#step-3-review-the-tls-configuration-settings)) I used a self signed certificate but in the end when I run this command:

```auto
influx -ssl -unsafeSsl -host <domain_name>.com

```

I get this error:

```
Failed to connect to https://<domain_name>.com:8086: Get https://<domain_name>.com:8086/ping: dial tcp: lookup <domain_name>.com on 172.16.0.1:53: no such host

Please check your connection settings and ensure 'influxd' is running.

```

(I changed \<domain\_name\> to my domain). I can’t get what I did wrong, does someone has an advice? The influxdb is installed and running on a raspberry pi 3b+. Thanks in advance

---

<div class="post-metadata">

### Author: ![Pooh](https://avatars.discourse-cdn.com/v4/letter/p/f05b48/32.png) [@Pooh](https://community.influxdata.com/u/Pooh)
#### Post date: [March 26, 2021, 11:58am UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/2 "2021-03-26T11:58:09Z")

</div>

You don’t want a _domain name_ there, you need a _host_ name.

For example, if your domain is [example.com](http://example.com) and your InfluxDB servre’s name is  
[data.example.com](http://data.example.com), you need to use [https://data.example.com:8086](https://data.example.com:8086) as the URL.

If that still gives you the same error, then you need to check DNS, not Influx,  
because the error is telling you that your specified hostname cannot be  
resolved by your DNS server at 172.16.0.1

Antony.

---

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 12:21pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/3 "2021-03-26T12:21:24Z")

</div>

mmh I’m really new here and in IoT so I didn’t get what you mean. If my influxdb is running on my raspberry pi how do I find the host name?

---

<div class="post-metadata">

### Author: ![Franky1](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/franky1/32/6666_2.png) [@Franky1](https://community.influxdata.com/u/Franky1)
#### Post date: [March 26, 2021, 12:34pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/4 "2021-03-26T12:34:30Z")

</div>

Can you tell a little more about your setup?  
I assume a home network?  
I assume your router has the ip address `172.16.0.1` and assigns an ip address `172.16.0.???` with DHCP to your raspberry. By default, any Raspberry Pi that uses Raspbian, the official OS, has `raspberrypi` as its hostname. Unless you change it.

What is the ip address of your raspberry?  
What does the router says about the hostname of your raspberry?  
On which machine did you run your `influx....` command?

---

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 12:59pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/5 "2021-03-26T12:59:39Z")

</div>

Exactly, home network with ip address 172.16.0.???  
I changed the host name to raspi-hyperink  
I’m running influx command from my mac’s terminal through ssh

---

<div class="post-metadata">

### Author: ![Franky1](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/franky1/32/6666_2.png) [@Franky1](https://community.influxdata.com/u/Franky1)
#### Post date: [March 26, 2021, 1:15pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/6 "2021-03-26T13:15:06Z")

</div>

I’m not sure you’re on the right track.  
What is your goal?

Have you registered a public domain?  
What happens when you `ping` this domain?  
Have you set up port forwarding in your router?

---

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 3:10pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/7 "2021-03-26T15:10:54Z")

</div>

No, I didn’t registered a public domain. I thought I could work locally using only the raspberry.  
Are there other ways to query the database?  
There’s a way to query the influx database from node-red without http request?

---

<div class="post-metadata">

### Author: ![Franky1](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/franky1/32/6666_2.png) [@Franky1](https://community.influxdata.com/u/Franky1)
#### Post date: [March 26, 2021, 3:36pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/8 "2021-03-26T15:36:40Z")

</div>

> [@Arianna\_parisi](#):
>
> I thought I could work locally using only the raspberry.

Yes of course you can.  
But you don’t necessarily need **https**.  
In any case, I would not start with it.  
I would start with **http** first.  
Is your InfluxDB configured and does it work with http?  
If all this works, then continue with https - if it is necessary at all.

In Node-Red, as far as I know, you can also simply enter the IP address of your local InfluxDB instance, e.g. `172.16.0.???:8086`  
Of course replace `???` with the right ip address in your home network.

---

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 3:49pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/9 "2021-03-26T15:49:13Z")

</div>

Well as I mentioned I followed this tutorial ([Enable HTTPS with InfluxDB | InfluxDB OSS 1.8 Documentation](https://docs.influxdata.com/influxdb/v1.8/administration/https_setup/#step-3-review-the-tls-configuration-settings)) but I’m not sure it’s the right way and it doesn’t work

---

<div class="post-metadata">

### Author: ![Franky1](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/franky1/32/6666_2.png) [@Franky1](https://community.influxdata.com/u/Franky1)
#### Post date: [March 26, 2021, 3:56pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/10 "2021-03-26T15:56:57Z")

</div>

Yes, you can do it that way.  
But you have to know what you are doing.  
A typo somewhere and nothing works.  
If you only work in your local home network I would leave out **https** for now.  
First get a simple setup working and then increase the complexity.

Therefore the question again:  
Is your InfluxDB configured and is it basically working?

---

<div class="post-metadata">

### Author: ![Arianna\_parisi](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/arianna_parisi/32/6957_2.png) [@Arianna\_parisi](https://community.influxdata.com/u/Arianna_parisi)
#### Post date: [March 26, 2021, 6:03pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/11 "2021-03-26T18:03:40Z")

</div>

Ok got it! But where do I find the tutorial for http? I really don’t know how to enable http

---

<div class="post-metadata">

### Author: ![Franky1](https://sea1.discourse-cdn.com/flex023/user_avatar/community.influxdata.com/franky1/32/6666_2.png) [@Franky1](https://community.influxdata.com/u/Franky1)
#### Post date: [March 26, 2021, 6:06pm UTC](https://community.influxdata.com/t/http-enable-influxdb-failed/19088/12 "2021-03-26T18:06:59Z")

</div>

You don’t have to enable http, it is already there. Just use it.
