Failed to validate Oauth settings: missing Google oauth setting[s] error after upgrade to 1.8.4

I upgraded my influxdb server today, like I did countless times before. After the upgrade, chronograf would not start. It logs the following error:

level=error msg=“Failed to validate Oauth settings: missing Google oauth setting[s]: client id, client secret” basepath=invalid component=server

I’m not even using Google OAuth, I have Generic OAuth configured in /etc/default/chronograf. All the settings are there as per the AzureAD generic OAuth configuration example.

I would really appreciate any pointers.

1 Like

@buzzlightyear thanks for the comment. We believe this issue was fixed in https://github.com/influxdata/chronograf/commit/00cce510f2fe250d9e0a14a306ab9f56293b0ce3 but has not been released yet. It is in master and the nightly available on https://portal.influxdata.com/downloads/. We are planning an updated release in the next few weeks.

Thanks @russ_savage I downgraded chronograf to 1.7.17 and back up and running.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.