Converting InfluxDBv2-beta10 into InfluxDBv2-rc1 fails

Hi! Using the guide here “https://docs.influxdata.com/influxdb/v2.0/reference/rc1-upgrade-guide/” I’ve ran into a few problems; I think I solved the issues as far as to point 7 (as in I followed the guide, or at least did what the guide wanted me to do as it’s NOT possible to use it exactly as written) but ended up with the following errors after getting so far:

root@telegraf-test: ~/.influxdbv2 # influx export all -c influx_old | influx apply -c default
Error: Yaml: mapping values are not allowed in this context.
See ‘influx apply -h’ for help
root@telegraf-test: ~/.influxdbv2 # influx export all -c influx_old
Error: Json: cannot unmarshal object into Go value of type pkger.Object.
See ‘influx export all -h’ for help

If anyone can guess what’s causing this or if you need any additional info plz contact me. I need to get this data from my DBv2-beta so that I can start using the latest-and-greatest DBv2 instead… Thanks!

regards, Einar

Hello @rayceem,
Welcome! I’m sorry you’re experiencing this problem and that this question went unanswered. Are you still having trouble? In the future, please tag me! I’m sharing your questions with the right people.

Hi @Anaisdg, I dont think it works now either. Been trying to use your migration guide without disabling integrations now as it feels quite stressy to lose data when just trying to get old data out. No luck sofar, might try with downtime tomorrow but I’m guessing I’ll still get the crashes from above (any ideas?).

Now I log all new data into a v2.0.2 as well as the old v2-beta10 but I’d really like to extract that old data as well and if I can do it without data loss that’d be even better. Thanks.

regards, Einar

The step in the instructions where you are getting the failure — is about moving dashboards and other resources from your current version to the GA release. I would recommend the following:

  1. download the last BETA (not the RC…but BETA 16). That should be a drop-in replacement for beta10. I believe there were a number of changes to the packager and related stuff for InfluxDB templates.

Here are the links:
Mac OS X
https://dl.influxdata.com/influxdb/releases/influxdb_2.0.0-beta.16_darwin_amd64.tar.gz
Linux Binaries (64-bit)
https://dl.influxdata.com/influxdb/releases/influxdb_2.0.0-beta.16_linux_amd64.tar.gz

  1. Retry Steps 7 through 9

Now, it may be that since you are already loading data into the new instance there may be a conflict re: the bucket name. But, it may just report that as a failure when you run the resource apply.

The part to move the data is in Step 9. The MOST important thing to do is to use the latest CLI (GA version) when performing the write. You can extract the data using the old CLI, but there have been a number of improvements to the new CLI to deal with batching writes, etc. So, that one is likely to work much better when you attempt to bring in the various CSV files created.

Please try that and let us know.

1 Like

Thank you Tim, I will try this. Was actually looking at upgrading from 10->11->12 and so on but it’d sure save some time to jump up to beta16 directly. :slight_smile: Looking at other stuff right now but will try this for sure, thank you so much for the answer! Will get back to you when I’ve tried it but might not be until next year as I’m currently fighting Grafana… :wink: